0

I can't download files from any BBS I've tried so far using the ZMODEM protocol in Debian 10.

So far, this is exactly what I have done:

  1. Marked the files I wanted to download from the BBS.
  2. Go to a specified Protocol Selection screen and selected ZModem 8k
  3. Got this message after the connection freezes and the download fails

�**B00000000000000 rz

I tried the same using telnet and ssh but also ztelnet and zssh (which as far as I understand are telnet and ssh implementations of zmodem). Every time I got the same results.

I tried running the rz command in a second terminal at the same moment. In which case I have this message

rz �z waiting to receive.**B0100000023be50

0ive.**B0100000023be50

For the record I have tried this both in lxterminal and terminator emulator terminals, on several BBS running several BBS systems. Have the following packages correctly installed:

lrzsz
minicom
seyon
zssh
cutecom

I'll really appreciate any help. Cheers!

4
  • I can't believe zmodem is still around! Interesting. How do you connect to the BBS? Is one of those BBS open so that we could try it? Mar 5 '20 at 19:51
  • How are you connecting to the BBS? The basic idea is to connect, say with zssh. You do whatever you want on the BBS, then get it to send the files. At this point you tell your communications program (zssh) to switch to a 'file receive mode', and the files are sent over the same connection. No point in running rz in a second terminal, you need things in the same connection.
    – icarus
    Mar 5 '20 at 19:55
  • It's fixed now! thanks a lot you both. Finally used ctrl + spacebar when the first message appeared on screen which took me to a zssh prompt. Type rz, hit enter and the download began. Silly me I didn't know I have to use rz in the same terminal session ...
    – Galeno
    Mar 6 '20 at 13:20
  • So what do you want to do with this question? Do you want to write up an answer?
    – icarus
    Mar 6 '20 at 17:05
0

I used Control + Space when the first message appeared on screen, which took me to a zssh prompt. Type rz, hit Enter and the download began. I didn't realize I had to use rz in the same terminal session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.