0

I have successfully compiled jacksonliam/mjpg-streamer. After compiling it, I ran into issues. The end result is that the source works, but I don't know how to resolve port conflicts under Debian Linux.

...

Port 8080 it seems is used on the source for using the webcam for getting online and promoting the webcam mjpeg-streamer source for webcam use.

I found that Apache2 and NodeJS both use the 8080 port. So, I erased them. I removed them from my machine.

I still do not know how to access the camera via web page b/c of not knowing how to initialize the port in question. I hope this makes sense.

P.S. I have covered a bunch of online tutorials regarding the basics of less, ncat, ss, etc. I am not completely sure what this means or how to search my files/directories for the 8080 port is taken up or not. Are there particular commands I need to know on how to see if my port 8080 is accessible?

  • /etc/services does not show what ports are 'taken up'; it's just a list of common names for ports. – muru Mar 2 at 6:45
  • Hello...okay. I will rephrase what I typed up. I read the link you posted. I guess I was a bit confused as how to ask this question. Thank you. – De Funct Mar 2 at 6:57
0

You can use netstat or ss to get the list of programs and users that are using a socket.

So for ss do

ss -lpe |grep 8080

for netstat do

netstat -ntpl |grep 8080

If nothing returns then nothing using 8080.

Both commands should return similar info in a bit different format. If you see an app using port 8080 you need to go to that apps config and change the port and restart the app (if you need that app) or if you dont need the app disable it. (replace appUsing8080 with the app name you found using that port with above commands)

systemctl disable appUsing8080 
systemctl stop appUsing8080
| improve this answer | |
  • Hello and thank you, Mr. Mark. I will test that out right now. – De Funct Mar 2 at 21:53
  • 1
    Hey sir...got it to work. I had to erase what I removed yesterday and just apply the command this time. Thank you, again. – De Funct Mar 2 at 22:22
  • Click solved if that worked out for you. TIA – Mark Stewart Mar 2 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.