0

I am trying to figure out why my LFS does not boot and would need some help.

The setup is built on a Ubuntu VMware VM. The sda is the drive where my Ubuntu is running on. LFS is built on sdb. sdb1 is root and sdb2 is swap.

To boot into LFS, I am detaching the HDD2 from my Ubuntu VM (which is my LFS disk), attaching it to a new VM as HDD1.

Initially, my GRUB was:

set default=0
set timeout=5

insmod ext4
set root=(hd1,1)

menuentry "GNU/Linux, Linux 5.2.8-lfs-9.0" {
        linux   /boot/vmlinuz-5.2.8-lfs-9.0 root=/dev/sdb1 ro
}

And my fstab was:

# file system  mount-point  type     options             dump  fsck
#                                                              order

/dev/sdb1     /            ext4    defaults            1     1
/dev/sdb2     swap         swap     pri=1               0     0

This ran into error for hd1 cannot get C/H/S values

So I assumed since I am attaching this drive to the new VM as HDD1 it needs it to be sda. So I updated my GRUB and fstab to below:

# Begin /boot/grub/grub.cfg
set default=0
set timeout=5

insmod ext4
set root=(hd0,1)

menuentry "GNU/Linux, Linux 5.2.8-lfs-9.0" {
        linux   /boot/vmlinuz-5.2.8-lfs-9.0 root=/dev/sda1 ro
}
# file system  mount-point  type     options             dump  fsck
#                                                              order

/dev/sda1     /            ext4    defaults            1     1
/dev/sda2     swap         swap     pri=1               0     0

Then it basically logs me into grub> and then if I do ls, I can see (hd0) (hd0, msdos1) (hd0, msdos2)

Then I did ls against them and saw which one had the ex4 set and did a set and set prefix and then attempted to boot, which led me back to the same grub> prompt.

Unsure what is configured wrong. Any help please?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.