0

I need to identify a my bluetooth pen in the /dev directory, because I want to create a udev rule for it. Unfortunately I can't find it. Can anyone help me?

0

Serial bluetooth devices which you typically connect via rfcomm are named with the same suffix. E.g. /dev/rfcomm0

If you connect your device in a different way, you should consider to use the belonging tool (which is in the most cases bluez/ bluetoothctl or hcitool).

For an udev-bluetooth example where hcitool is used, have a look at Making udev rule for bluetooth keyboard

| improve this answer | |
  • I have no rfcomm0 listed in /dev. I also tried the solution for the bluetooth keyboard, but it doesn't work. My devices hidraw0 and hidraw1 are the Wacom tablet and not the pen. I tried to access the pen via its MAC address, but without success. hcitool seems to be deprecated and I can't access bluetoothctl. I actually don't care how to accomplish this. I just want to map a command to this button – neolith Mar 2 at 19:30
  • I would bet the pen is not connected directly to your device. Only the whole tablet and the tablet recognize the actions of the pen and send it to your device (but maybe the hidraw1 could be the stylus). In your case I would go trough the driver (possible the X Driver) to remap buttons and not via udev. I don't know which distribution you have, but maybe you can find something useful here: wiki.archlinux.org/index.php/Wacom_tablet#Remapping_buttons and the driver overview here linuxwacom.github.io – Maze Mar 2 at 23:35
  • If you need further helps, ask another a more specific question here like "Remap button of wacom stylus" and provide information about your kernel version and distribution (or edit your question here to be more specific). – Maze Mar 3 at 14:14
  • I am pretty sure that it connects to the device. There are three buttons on the pen and two of them are configurable via the Wacom utility. The third one establishes a bluetooth connection. As long as you press the button the device can connect to "Bamboo Ink" via bluetooth. When you release the button, the pen disconnects. So I am pretty sure that his is the right way. It is just hard to find the right information for the udev rule. I already wrote an extended explanation here, but nobody responded. – neolith Mar 4 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.