1

I am using KDE neon.

After I installed MiKTeX, I updated everything from it, downloaded the "standard package" and then tried to install TeXStudio... a message appeared "installation failed". But TeXStudio is fine. I can run it.

I go to MiKTeX Console... and suddenly I am unable to enter, getting this message: MiKTeX Error Report

Panic ensues. MiKTeX actually says in their documentation that entering the console is needed to first restore initial status to fully uninstall it.

But I can't.

Trying

sudo apt-get purge miktex

does nothing good.

It says that there is an empty file, the same thing as when you try to open the console:

miktexsetup: File is empty. path="/home/MYUSERNAME/.miktex/texmfs/data/miktex/data/le/90a0591fc444a4d943d26e2f84799e00.fndb-5"


When executing

$ sudo dpkg --remove --force-remove-reinstreq miktex

I get this:

(Reading database ... 174113 files and directories currently installed.)
Removing miktex (2.9.7300-bionic1) ...
miktexsetup: File is empty.
miktexsetup: Data: path="/home/MYUSERNAME/.miktex/texmfs/data/miktex/data/le/90a0591fc444a4d943d26e2f84799e00.fndb-5"
dpkg: error processing package miktex (--remove):
 installed miktex package pre-removal script subprocess returned error exit status 1
Errors were encountered while processing:
 miktex

What am I supposed to do?

MiKTeX Console still appears as if it is still a program.

2
  • unrelated to your problem, but personally I would recommend to use texlive instead of miktex on linux - much larger user base and better tested. – samcarter_is_at_topanswers.xyz Mar 1 '20 at 9:20
  • Yes, I actually tried to do it, but as MiKTeX was installed, errors and errors ensued. – ivanovitx Mar 1 '20 at 9:35
2

I more or less solved it.

I straight up deleted ~/.miktex like this:

sudo rm -rf ~/.miktex

and I reopened the console freely, and proceeded with the clean uninstall like here: https://askubuntu.com/a/1139034/1048142

1
  • That means some part of your user configuration was borked. – vonbrand Mar 1 '20 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.