0

I have Mint 19.3 Gnome/Xfce installed on an old Dv7 HP laptop and a WDTVLive Hub on the network with 2tb internal and 2 external HDD connected acting as a NAS.

I want to automount the shares(internal, HDD(1tb) & HDD(2tb)) so I can use them with Plex Media Server on the Mint machine.

The shares can be seen in the file explorer in Mint. I can access the folders and files in file explorer no problem.

I created a directory /media/shares/ where I would like to add the shares. I need help determining what the parameters are for mounting the shares.

$ sudo smbstatus
Samba version 4.7.6-Ubuntu

$ sudo less /etc/passwd | grep plex      
plex:x:999:999::/var/lib/plexmediaserver:/usr/sbin/nologin

$ id
uid=1000(tjohannes) gid=1000(tjohannes) groups=1000(tjohannes),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),112(lpadmin),129(sambashare)

$ net lookup wdtvkids
192.168.1.95

$ smbtree
MEDIACENTER
    \\WDTVKIDS              WDTV LIVE
        \\WDTVKIDS\IPC$             IPC Service (WDTV LIVE)
        \\WDTVKIDS\Seagate_Backup_Plus_Drive    Seagate_Backup_Plus_Drive
        \\WDTVKIDS\New_Volume       New_Volume
        \\WDTVKIDS\WDTVLiveHub      WDTVLiveHub

$ sudo smbclient -L 192.168.1.95 -U%
WARNING: The "syslog" option is deprecated

    Sharename       Type      Comment
    ---------       ----      -------
    WDTVLiveHub     Disk      WDTVLiveHub
    New_Volume      Disk      New_Volume
    Seagate_Backup_Plus_Drive Disk      Seagate_Backup_Plus_Drive
    IPC$            IPC       IPC Service (WDTV LIVE)
Reconnecting with SMB1 for workgroup listing.

    Server               Comment
    ---------            -------
    WDTVKIDS             WDTV LIVE

    Workgroup            Master
    ---------            -------
    MEDIACENTER          WDTVKIDS

I'm not sure what parameters are needed. I added a user/pass and changed the workgroup to WORKGROUP. This is what I have so far based on the above info sudo mount -t cifs //192.168.1.95/New_Volume /media/share -o user=user,password=pass,workgroup=WORKGROUP but it returns mount error(2): No such file or directory

Any help would be appreciated.

  • If that screenshot is of the laptop where you have Mint installed, then it looks like those shares are mounted or else they wouldn't appear. Can you go into the folders and see the contents? Is there something else in /etc/fstab that could be causing that error? Add the contents of /etc/fstab to the question. – Nasir Riley Feb 29 at 8:45
  • 3
    did you actually put quotes into your fstab? – SparedWhisle Feb 29 at 9:13
  • Thanks for the reply. No quotes in the fstab and I will add it to the question. The shares are mounted by simply accessing them through the file manager and yes the folders and files are available to view(I have not tried to open any of the files). The problem is not mounting per se but autmounting with fstab. – rebellelouch Feb 29 at 19:25
  • Does mount -t cifs -o uid=999,gid=999,guest,iocharset=utf8 //192.168.1.95/New_Volume /media/share work (as root)? If not, the issue isn't with fstab it's with your mount parameters. – roaima Feb 29 at 23:33
  • 1
    Please try adding vers=1.0 to the mount options. If that still fails then replace 1.0 with 2.0, 2.1, 3.0 in turn. Keep the highest value that works. – roaima Mar 1 at 13:21
1

Please try adding vers=1.0 to the mount options. If that still fails then replace 1.0 with 2.0, 2.1, 3.0 in turn. Keep the highest value that works.

What you're doing here is downgrading the SMB version from the current (3.1) to the oldest (1.0). Many older devices still only use SMB version 1.0.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.