0

I just bought a Raspberry Pi 4 which uses linux as its operating system. I was just trying to browse the internet using my phone hotspot when the connection suddenly drops, I can't access any other webpages on chromium with message ERR_NAME_RESOLUTION_FAILED.

I also noticed that the wifi logo (at the top right) keeps on showing the connecting animation (where the signal goes from the circle to the last bar at the top), it might indicate that my device is not connected to the network.

Also, when I tried to do ping 8.8.8.8, here is the response:

connect: Network is unreachable

While with ping google.com:

ping: google.com: Temporary failure in name resolution

I have been trying several guides such as changing the resolv.conf to 8.8.8.8 or changing the dhcpcd.conf file but to no avail.

Am I missing something here? I am new to Linux or Raspeberry Pi in general so any help would be appreciated. Thank you.

Here is the content of /etc/resolv.conf:

# Generated by resolvconf
nameserver 192.168.43.1

And the result of ifconfig (wlan0 part):

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.243.132.27 netmask 255.0.0.0 broadcast 10.255.255.255
ether dc:a6:32:4c:ba:36 txqueuelen 1000 (Ethernet)
RX packets 4 bytes 496 (496.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 429 bytes 95691 (93.4 KiB)
TX errors 0 dropped 0 overrunes 0 carrier 0 collisions 0

Update: another hint, I checked from my phone and found out that my phone doesn't detect any connected devices, so it seems that my rpi 4 is unable to connect to the hotspot, however, I tried with 3 different phones and still has the same case, so the problem is not from my hotspot.

0

Solved it myself !

I am not sure why but I go to the /etc/dhcpcd.conf file and found that there are so many random configurations on the file. I deleted those entries and the wifi works correctly

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.