2

set complete = enhance is put in .cshrc, and we have two files, test_ab_dd.c and test_abc_dd.c.

If I type test_ab_<TAB> in the command line, csh DOES NOT autocomplete to test_ab_dd.c. It suggests both test_ab_dd.c and test_abc_dd.c. I have to type all the way to the end. Shouldn't this no longer be ambiguous? It completes just fine in bash.

This only happens with complete set to enhance. I wanted it that way since it allows case-insensitivity.

Is there any way to keep case-insensitivity while resolving this issue?

1

When you set complete to enhance it considers periods, hyphens and underscores as word separators and not as the characters like you expected.

So basically the answer is no since this is a "feature" of setting complete to enhance.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.