0

When I start copying to a samba share on higher speeds (e.g. >20MB/s), something with CIFS breaks. Kernel log is spammed with:

[20152.052310] INFO: task rsync:4111 blocked for more than 122 seconds.
[20152.052314]       Tainted: P           OE     5.4.15-2-MANJARO #1
[20152.052315] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[20152.052317] rsync           D    0  4111   4110 0x80004000
[20152.052320] Call Trace:
[20152.052328]  ? __schedule+0x2f3/0x770
[20152.052331]  schedule+0x43/0xd0
[20152.052333]  io_schedule+0x12/0x40
[20152.052336]  wait_on_page_bit+0x139/0x230
[20152.052338]  ? file_fdatawait_range+0x20/0x20
[20152.052340]  __filemap_fdatawait_range+0x8b/0xe0
[20152.052343]  filemap_write_and_wait+0x5a/0x90
[20152.052367]  cifs_flush+0x76/0x80 [cifs]
[20152.052371]  filp_close+0x32/0x70
[20152.052372]  __x64_sys_close+0x1e/0x50
[20152.052375]  do_syscall_64+0x4e/0x140
[20152.052377]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[20152.052380] RIP: 0033:0x7f1509520c37
[20152.052384] Code: Bad RIP value.
[20152.052385] RSP: 002b:00007ffe6a7b8f58 EFLAGS: 00000246 ORIG_RAX: 0000000000000003
[20152.052387] RAX: ffffffffffffffda RBX: 00007f1508e1b940 RCX: 00007f1509520c37
[20152.052388] RDX: 000056325b8e47ce RSI: 0000000000000000 RDI: 0000000000000001
[20152.052388] RBP: 00007ffe6a7b9060 R08: 0000000000000000 R09: 0000000000000001
[20152.052389] R10: 00000000ffffffff R11: 0000000000000246 R12: 00007ffe6a7b9060
[20152.052390] R13: 000000000000002b R14: 00007ffe6a7ba060 R15: 0000000000000000

and not only CIFS mounts, but all mounts, are sluggish or outright stop working. Only workaround I found is restart and switch NIC to lower speed. It's very inconvenient having to restart in middle of a work, I would appreciate a good way to fix this (without lowering speed).

3
  • is it happens also when you are not using rsync? Feb 26, 2020 at 13:13
  • @darcy-nader Yes. For example when using doublecmd it's even worse (it usually leaves doublecmd process as defunc and the process will hang indefinitely while being un-killable).
    – menfon
    Feb 26, 2020 at 13:29
  • it does that on every cifs mount or only one in particular? if you are using rsync, you could try to lower the i/o bandwith with the parameter --bwlimit=KBPS and if it gets stuck again , try to use umount -l /your_cifs/mountpoint/ ... i have no other idea. Feb 26, 2020 at 13:36

0

You must log in to answer this question.

Browse other questions tagged .