I am attempting to run a dnsmasq instance (in addition to the system wide instance on Ubuntu 18). I ran it once and it worked fine. But then I killed it with

kill -15 <dnsmasq_pid>

Now whenever I try to run dnsmasq I get

dnsmasq: unknown interface wlx00c0caa5587f

But this interface exists in ifconfig:

wlx00c0caa5587f: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:c0:ca:a5:58:7f  txqueuelen 1000  (Ethernet)
        RX packets 139  bytes 26260 (26.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 190  bytes 37131 (37.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Here is my config file:




Why can I run this once but not again?

Any help would be great.

  • You have better to start/stop the dnsmask as the service. By killing it, you may left some of it's threads keeping the interface on.
    – schweik
    Commented Feb 25, 2020 at 22:41
  • That interface isn't configured (no IP address, etc) - is that expected? Commented Feb 25, 2020 at 22:45
  • @roaima you were right. Needed to set static IP. Don't know why. I guess dnsmasq requires that for some reason
    – CarterKF
    Commented Feb 26, 2020 at 16:44

1 Answer 1


It looks like dnsmasq doesn't like it if the interface doesn't have an IP address. The command that worked for me was

sudo ifconfig wlx00c0caa5587f netmask up

Keep in mind two things. This only sets a temporary IP for the interface. And the need to exclude this IP from your dhcp range.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .