0

I found an update for chrome and I updated the system, and the next time I restarted chrome it did not want to open. Nothing was updated except chrome.

When I opened chrome from the terminal nothing appeared to happen until I tried

1

sudo google-chrome --no-sandbox this method opened chrome so I tried to change the file: /usr/share/google-chrome.desktop and switched those lines:

"Exec=/usr/bin/google-chrome-stable" 
"Exec=/usr/bin/google-chrome-stable %U"

to

"Exec=sudo /usr/bin/google-chrome-stable --no-sandbox"

saved and yet nothing got resolved.

2

sudo apt-get purge google-chrome-stable It got uninstalled but the .config files remained in their place and the .cache also, so I had to delete them myself and then I reinstalled chrome to find that it was not just installed, but actually it signed in to everything I was signed into before I uninstall it; as if I did nothing. I tried my best for 2 pages of google with nearly the same answer, but to no avail.

3

sudo apt-get install libnss3 tried this one as nearly all solutions was regarding that firefox has updated a file the chrome rely on which is "libnss3" but also this did not help

Is there any solution to completely uninstall chrome from the entire system not just "purge" that did not uninstall and delete all files? is there any solution to this particular issue?

10
  • 1
    Where did you find it? Why Oh why oh why, did you run in with sudo? And why with --no-sandbox? Feb 25, 2020 at 20:15
  • It looks like you missed some config files. You did not delete them all. Feb 25, 2020 at 20:16
  • Also have a look at .local and at this (and both of our other folders) in the /root folder, not only in your home. Do a strace google-chrome-stable and look for pathes it tries to open, delete everything not in system pathes. Purge Chrome
    – Jaleks
    Feb 25, 2020 at 21:28
  • Re. "but actually it signed in to everything I was signed into before I uninstall it; as if I did nothing" ... maybe you have your account synced. So first turn off sync, then purge, then delete your ~/.config/google-chrome folder and AFAICT, one shouldn't really run browsers with sudo (already mentioned in the first comment).
    – DK Bose
    Feb 26, 2020 at 3:39
  • yes, i do not run any browser with sudo, it was just my only solution to get chrome running again. the solution was provided in this link: youtube.com/watch?v=OOYwEAmCFpc Feb 26, 2020 at 6:55

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.