0

I've got Arch Linux and I can't install Foxit Reader from AUR. It fails when building gstreamer0.10. The source of the error is that it can't find a Python package called giscanner._giscanner.

Here are what I think are the relevant lines for the error:

/usr/include/glib-2.0/glib/deprecated/gthread.h:153:8: note: declared here
  153 | struct _GStaticRecMutex
      |        ^~~~~~~~~~~~~~~~
  CCLD     libgstreamer-0.10.la
  GEN      Gst-0.10.gir
Traceback (most recent call last):
  File "/usr/bin/g-ir-scanner", line 99, in <module>
    from giscanner.scannermain import scanner_main
  File "/usr/lib/gobject-introspection/giscanner/scannermain.py", line 35, in <module>
    from giscanner.ast import Include, Namespace
  File "/usr/lib/gobject-introspection/giscanner/ast.py", line 29, in <module>
    from .sourcescanner import CTYPE_TYPEDEF, CSYMBOL_TYPE_TYPEDEF
  File "/usr/lib/gobject-introspection/giscanner/sourcescanner.py", line 33, in <module>
    from giscanner._giscanner import SourceScanner as CSourceScanner
ModuleNotFoundError: No module named 'giscanner._giscanner'
make[4]: *** [Makefile:2033: Gst-0.10.gir] Error 1
make[4]: Leaving directory '/home/tomas/.cache/yay/gstreamer0.10/src/gstreamer-0.10.36/gst'
make[3]: *** [Makefile:1571: all-recursive] Error 1
make[3]: Leaving directory '/home/tomas/.cache/yay/gstreamer0.10/src/gstreamer-0.10.36/gst'
make[2]: *** [Makefile:908: all] Error 2
make[2]: Leaving directory '/home/tomas/.cache/yay/gstreamer0.10/src/gstreamer-0.10.36/gst'
make[1]: *** [Makefile:750: all-recursive] Error 1
make[1]: Leaving directory '/home/tomas/.cache/yay/gstreamer0.10/src/gstreamer-0.10.36'
make: *** [Makefile:654: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
Error making: gstreamer0.10

I'm not sure if that would help but I reader somewhere that I should install glib, but that changed nothing.

PS: I found out I can install it manually through the Foxit Reader installer (and it works), but I'm trying to install via yay so that I can keep it updated through there.

1 Answer 1

1

There is an issue with dependencies of gstreamer0.10.

Updating the python to the version 3.8 (from 3.7) solved the problem.

1
  • This worked for me by updating to python 3.9
    – sokato
    Mar 12, 2021 at 19:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .