If I create a test pdf file in a directory, by using something like

ls -al > testpdf.pdf

the file is shown in Caja 1.4.0 with an understandable emblem that is 'acrobat-like'.

If I create a LibreOffice document in Writer and export it to PDF in the same directory, its emblem is a grey 'sheet of text' which makes it very hard to spot.

How can I change the icon/emblem used by PDFs created by LibreOffice?

Can I just overwrite the file used somewhere in /usr/shr/icons? If so, will it be overwritten by the next LibreOffice update?

  • On Linux, a lot of file manager detect the file type not by extension but by looking at the content of the file. So if you create .pdf files with non-pdf content, you get usually other icons than for real pdf files. Usually, you can select in the options of a file which icon should be used for the corresponding file type.
    – jofel
    Aug 1, 2013 at 15:26
  • Is that icon trademarked perhaps?
    – Rob
    Sep 6, 2013 at 11:43

1 Answer 1


This sounds more like an issue of the file manager not properly recognising the file type - almost as if it used the extension to infer it (which is rather obsolete imho). Does your pdf's name (the one exported from libreoffice) end with .pdf?

/usr/share/icons (basically everything under /usr, /lib*, /etc) is "system" owned and may be overwritten on package updates (with the exception of configuration files which are treated slightly differently).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .