5

After switching to systemd, I started to use NetworkManager.service, I got connected to WIFI automatically at boot, but I got the following message when I run nmcli con:

** (process:4433): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

Error: nmcli (0.9.6.4) and NetworkManager (unknown) versions don't match. Force execution using --nocheck, but the results are unpredictable.

And from systemctl:

NetworkManager.service                              loaded active running       Network Manager

Now if I restart NetworkManager.service, it works. Why is that?

5
  • “nmcli (0.9.6.4) and NetworkManager (unknown) versions don't match”. Have you tried fixing that? Where do nmcli and NetworkManager come from? – Gilles 'SO- stop being evil' Nov 28 '12 at 0:19
  • @Gilles they both belong to networkmanager 0.9.6.4-1, official repository of Arch, and it looks like a DBUS problem – daisy Nov 28 '12 at 0:21
  • I have a similar anomaly. NetworkManager will drop the wireless connection after a while and NetworkManger restart is required. Arch Linux and Gnome 3.6 on systemd – keepitsimpleengineer Nov 30 '12 at 22:21
  • After deprecating Gnome 3.6 and fresh install of ArchLinux/Xfce 4.1, the problem still occurs. In addition, after restart of NetworkManager.service, the NetworkManger applet disappears. – keepitsimpleengineer Dec 8 '12 at 19:16
  • @keepitsimpleengineer i don't know, but the problem disappeared now ... and I don't use a panel – daisy Dec 9 '12 at 0:35
5

This is a known issue and several bug reports have been submitted.

There is also a workaround for ubuntu, but I don't think it will work for Arch users because they no longer use init scripts. I bet their fix can be ported but I don't know enough about systemd to do it.

Here is a solution from the Fedora forums that looks like it works:

  • Right-click on the NetworkManager applet
  • Edit Connections
  • Click the Wireless tab (if that's what you're using)
  • Select your connection and click the Edit button
  • Go to the IPv4 Settings tab
  • Click the Routes button
  • Check "Use this connection only for resources on its network."
  • Press OK
  • Uncheck "Available to all users"
  • Press Save
1

I had that issue on CentOS 7 and I did this as root:

systemctl mask network

That command blocks network.service. That is because network.service and NetworkManager.service do the same thing and sometimes, one service does not allow the other to work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.