I use Kerberos authentication in Thunderbird, Firefox and for ssh and it works just fine if I use the programs from the shell. But when I use i3-dmenu-desktop to start Thunderbird and Firefox, the Kerberos ticket is not "attached".

I use kinit with a cache file, which is exported in my .bashrc (KRB5CCNAME). I do not really know how dmenu works. Is it normal that it does not "inherit" environment variables?

  • 1
    How do you start i3? From a display manager or via xinit (startx)? If the latter, you might need to exit i3, log out and start i3 again. If the former, then yes, the window manager is not launched from the shell and therefore does not have the same environment variables (cf. LightDM)
    – stefan0xC
    Feb 24, 2020 at 16:48
  • I use startx. Setting the environment variable before "exec i3" in .xinitrc actually works, so this is kind of a no-brainer. I wonder why I did not try it before. Thanks a lot! Feb 25, 2020 at 12:52
  • @JohannesTitz it sounds like you've found an answer; would you please write it up as such? Thank you!
    – Jeff Schaller
    Feb 21, 2021 at 15:44

1 Answer 1


stefan0xC gave the correct hints. I will answer myself after the comment by Jeff Schaller.

Just add:

export KRB5CCNAME=path

in your .xinitrc (before launching a window manager, in my case i3), where path is the path to the krbcache file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .