0

I have two node servers with SAN storage. Each node have RHEL 6.9 with HA and the partition are mapped from the storage using fiber cables with clustered resources.

The thing is when the two nodes are working everything is fine. When one node is completely removed and the other node rebooted the clustered service will not work if there is no ping to the other node with the managment port.

Then after starting the second node the cluster start ok.

Fencing are configured ok.

Server model Dell emc R640

Storage Dell Me4012

What is this? Misconfiguration??

0

What do you mean the clustered service does not work? What is the filesystem that you're using for this cluster solution? What is the status of clvmd (if this is used)? The cluster quorum should have a fence device. Without a fence device, you could end up with split-brain functionality and corrupted data (depending on your setup). What is the status of the filesystem mount What is the status of clvmd? Have you tried to start all the services you need manually? clustat ?

| improve this answer | |
  • I mean there is clustered resources that mount file system partition as ext4 form the storage when the cluster start.. The status of clvmd is running for both nodes but when one node down completely form the power and you reboot the other node the clvmd will not start on boot.. Showing time out.. Quorum and fencing are configured properly.. And yes i have tried to start rgmanager but it's not starting and clustat are not showing the resources required.. Note that in this resources there is a file system mounting and virtual ip for database as required and script for application. – user65285 Feb 21 at 15:57
  • Once you start the other node and you do network restart on the other node.. Everything start normal. – user65285 Feb 21 at 16:00
  • Also mounting the file systems partitions form the storage works but cluster will not work. – user65285 Feb 21 at 16:02
  • Ok , if clvmd does not start then you have an issue with cman. service cman status / systemctl status cman. Anything specific in /var/log/messages? You have cman > clvmd > GFS? any fence device? – Karov Feb 21 at 16:16
  • check ccsd, fenced and groupd services status as well. – Karov Feb 21 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.