0

I have a customized layout, but it keeps (what seems to be randomly) changing to default, I am not sure what I need to do more:

// cat .profile
setxkbmap -layout fr2

denis:~ $ uname -r
4.15.0-62-generic

denis:~ $ cat /etc/os-release 
NAME="Linux Mint"
VERSION="18.3 (Sylvia)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 18.3"
VERSION_ID="18.3"
HOME_URL="http://www.linuxmint.com/"
SUPPORT_URL="http://forums.linuxmint.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/linuxmint/"
VERSION_CODENAME=sylvia
UBUNTU_CODENAME=xenial

3
  • A layout of what: Windows, icons, cuddly toys? Feb 21, 2020 at 10:49
  • what? xkb is about keyboard
    – dgan
    Feb 21, 2020 at 20:31
  • @mosvy thinks for the edit, it makes sense now, that you have put xkb in the title. Feb 22, 2020 at 10:19

1 Answer 1

0

Several distros are having this problem. Create a .desktop file with the setxkbmap code and put it in ~/.config/autostart/. To keep the configuration, use this command.

gsettings set org.gnome.settings-daemon.plugins.keyboard active false

If the command won't work, others have reported using something other than ibus or disable any screen locking that might reload the default layout.

5
  • thank you, i ll try this out
    – dgan
    Feb 21, 2020 at 20:32
  • Ok well, for future reference, this is not enough
    – dgan
    Apr 6, 2020 at 8:10
  • It depends on the compositor you're using. Or go back to using X instead of Wayland, which can't handle keymaps. unix.stackexchange.com/questions/309580/…
    – hellork
    Apr 7, 2020 at 22:31
  • I am not under Wayland, and never was..
    – dgan
    Apr 8, 2020 at 9:36
  • 1
    Changed from Cinnamon to MATE, which doesnt have this problem. Not a fix, but works for me lol
    – dgan
    Apr 23, 2020 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.