6

How can I increase the size of these System Tray Icons? :

enter image description here

Update: In Debian 11, KDE Plasma 5.20.5, there is now an option to scale system-tray icons to the panel's height. Here's is a short video showing that. Thanks goes to KDE!

4
  • 1
    @DKBose : plasmashell 5.16.5 Commented Mar 16, 2020 at 3:29
  • @DKBose : Well, I'm not sure this will help, but I remember having to insert the iconSize=3 line about 3 times (maybe its because I have 3 monitors and each one has a system tray on a tool bar), but each time I added a new line directly under the line that started extraItem=. . . and then put iconSize=3 onto that new line. After saving those changes to the file, and rebooting, the system tray icons where way bigger (like I like them). Commented Mar 16, 2020 at 3:43
  • @DKBose If you discover what works in 20.04 be sure to post back here. I intend to upgrade to that in April and I'm enjoying this hack in 19.10. Commented Mar 16, 2020 at 4:27
  • 1
    Update: reddit.com/r/kde/comments/fjf6jv. The responder there is a KDE dev. In any case, I'd suggest waiting for 20.04.1 sometime around October 2020, testing in a VM or via a USB stick, and then doing a clean install.
    – DK Bose
    Commented Mar 17, 2020 at 3:47

4 Answers 4

5

Open ~/.config/plasma-org.kde.plasma.desktop-appletsrc with a text editor.

Find every line starting with extraItems=

Add another line iconSize=3 below each of those.

Save the edited file and exit.

After a reboot the icons should have a much higher limit of size when adjusting the height of the panel.

6
  • 1
    Oooh, that's fantastic. It should do that by default. At the very least, you should be able to right-click on the system-tray and configure this setting instead of having to modify some text files. Thanks for the help! Commented Feb 20, 2020 at 22:05
  • It doesn't work for me, Plasma Systemtray version 1.0, shell version 5.20.2
    – xryl669
    Commented Nov 13, 2020 at 12:15
  • @xryl669 - From 5.19 you have to look for other tricks, like here. And isn't there a new setting under "Configure System Tray" that lets icons resize with the panel? (I'm in 5.18 now)
    – cipricus
    Commented May 9, 2021 at 16:18
  • Thanks again for showing me this solution; it got me through Kubuntu 20.04. Today I noticed that KDE Plasma (5.20.5) now provides this as an option in the GUI. It comes default in Debian 11. Commented Nov 16, 2021 at 18:52
  • You do not have to reboot, it's possible just to reload Plasma and surprisingly it works: askubuntu.com/questions/481329/…
    – oblalex
    Commented Jan 7, 2022 at 10:03
4

Debian 11, KDE Plasma

In order to increase the size of systray icons, you need to edit the file

/usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/ui/main.qml
  1. Find the string readonly property int smallIconSize: units.iconSzie.smallMedium

  2. Replace smallMedium (22 log. px) with medium (32 log. px), large, or use integer value (in physical pixels!)

  3. Save, log out, log in, or restart Plasma with

    killall plasmashell ; kstart plasmashell
    

This file will get overwritten every time there's a Plasma update. To edit settings for a specific user only and avoid problem with plasma update, copy the entire plasmoid (systemtray):

cp -r /usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray ~/.local/share/plasma/plasmoids/

and then edit main.qml and restart plasmashell.

2

FYI, this has changed as of Plasma version 5.21.4 (perhaps slightly earlier). The iconSize setting now does nothing.

To get this functionality, instead, at the same place where you would have inserted iconSize (per the other answers), put: scaleIconsToFit=true

Then simply killall plasmashell; plasmashell & as described and it will work perfectly.

6
  • what works in newer Plasma is the new setting under "Configure System Tray" that lets icons resize with the pnel
    – cipricus
    Commented May 3, 2021 at 22:00
  • @cipricus I think I recall that being there too, but IIRC it was for fixed sizes and for me all of them were too small or too big.
    – mikev
    Commented May 9, 2021 at 4:22
  • the version changes involved came (as many others) with 5.19.x. Now I'm back to 5.18 (kubuntu 20 LTS, so this answer works for me), but it's always good to have a solution for the future :)
    – cipricus
    Commented May 9, 2021 at 16:14
  • 1
    @cipricus ok. This works in the newer plasma too, is what I'm saying. (5.21.4, Kubuntu 21.04).
    – mikev
    Commented May 10, 2021 at 17:56
  • 1
    This makes the icons gigantic when using a wider vertical panel. It would be nice to have an option to simply set the size in pixels or similar.
    – tomasz86
    Commented Jul 2, 2021 at 14:10
1

The setting to change icon sizes, located in Settings > Appearance > Icons > Advanced, seems to have been unusable for years. I think this has been the case since some version of KDE 4. Possibly it is related to whether the icon theme is in a resolution-independent format (svg).

A hidden iconSize setting was added around plasma-workspace 5.9. Prior to the addition of this setting, qml files had to be edited.

To change the setting system-wide, edit the file:

/usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/config/main.xml

This file will be overwritten whenever plasma-workspace is reinstalled or updated.

To change the setting for a specific user, edit:

$HOME/.config/plasma-org.kde.plasma.desktop-appletsrc

Look for the entry that corresponds to the system tray. It will look something like this:

[Containments][#]
...
plugin=org.kde.plasma.private.systemtray
...

Then scroll down until you see something that looks like this:

[Containments][#][General]
extraItems=...
knownItems=...
showAllItems=true`

Then add:

iconSize=#

Where # is a number that refers to one of the following options:

0 ~ Small
1 ~ SmallMedium
2 ~ Medium
3 ~ Large
4 ~ Huge
5 ~ Enormous

To see the changes log off and on. Or kill and restart plasmashell in a terminal window:

killall plasmashell ; sleep 1 ; kshell5 plasmashell
2
  • Sounds cool, but on my system (plasma-workspace 5.18.5) iconSize=2 is too big, 0 is too small, 1 is same as 0. Display is 14' and 4K, I've adjusted few settings to make it look ok and icon size is last one to fix :) Commented Dec 26, 2020 at 4:48
  • @DmitriyVinokurov Seems like a bug if 0 and 1 behave the same. I don't have any 4k displays, so may be related to that. I'm currently using 5.19.5.
    – xiota
    Commented Dec 26, 2020 at 8:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .