0

I would like to suppress the "Thank you for being patient..." update message of xorriso 1.5.2 and display more information about the percentage instead.

My current command:

xorriso -as mkisofs -o "$ISOFILE" -V "$ISO_VOLUME_NAME" \
-c isolinux/boot.cat -b isolinux/isolinux.bin -no-emul-boot -boot-load-size 4 \
-boot-info-table -eltorito-alt-boot -e images/efiboot.img -no-emul-boot -R -J .

Output of it:

xorriso 1.5.2 : RockRidge filesystem manipulator, libburnia project.

Drive current: -outdev 'stdio:test.iso'
Media current: stdio file, overwriteable
Media status : is blank
Media summary: 0 sessions, 0 data blocks, 0 data,  522g free
xorriso : WARNING : -volid text does not comply to ISO 9660 / ECMA 119 rules
Added to ISO image: directory '/'=''
xorriso : UPDATE :      40 files added in 1 seconds
xorriso : UPDATE :      40 files added in 1 seconds
xorriso : UPDATE :  13.64% done
xorriso : UPDATE :  81.81% done
xorriso : UPDATE : Thank you for being patient. Working since 2 seconds.
xorriso : UPDATE : Thank you for being patient. Working since 3 seconds.
xorriso : UPDATE : Thank you for being patient. Working since 4 seconds.
xorriso : UPDATE : Thank you for being patient. Working since 5 seconds.
xorriso : UPDATE : Thank you for being patient. Working since 6 seconds.
xorriso : UPDATE : Thank you for being patient. Working since 7 seconds.
xorriso : UPDATE : Thank you for being patient. Working since 8 seconds.
ISO image produced: 339446 sectors
Written to medium : 339446 sectors at LBA 0
Writing to 'stdio:test.iso' completed successfully.

With xorriso 1.3.6 it was like this:

xorriso : UPDATE : 41 files added in 1 seconds
xorriso : UPDATE : 41 files added in 1 seconds
xorriso : UPDATE :  0.05% done
xorriso : UPDATE :  4.83% done
xorriso : UPDATE :  14.43% done, estimate finish Wed Feb 19 10:46:36 2020
xorriso : UPDATE :  21.72% done, estimate finish Wed Feb 19 10:46:36 2020
xorriso : UPDATE :  28.96% done, estimate finish Wed Feb 19 10:46:36 2020
xorriso : UPDATE :  36.67% done, estimate finish Wed Feb 19 10:46:36 2020
xorriso : UPDATE :  43.44% done, estimate finish Wed Feb 19 10:46:36 2020
xorriso : UPDATE :  50.68% done, estimate finish Wed Feb 19 10:46:36 2020
xorriso : UPDATE :  57.92% done, estimate finish Wed Feb 19 10:46:36 2020
xorriso : UPDATE :  62.75% done, estimate finish Wed Feb 19 10:46:37 2020
xorriso : UPDATE :  67.57% done, estimate finish Wed Feb 19 10:46:37 2020
xorriso : UPDATE :  74.81% done, estimate finish Wed Feb 19 10:46:37 2020
xorriso : UPDATE :  84.47% done, estimate finish Wed Feb 19 10:46:36 2020
xorriso : UPDATE :  89.29% done
xorriso : UPDATE :  96.53% done

I would like to get same output with the new version that I'm using now.

Maybe there's a parameter for that? :)

Thank you in advance!

  • Why don't you use the original program mkisofs? mkisofs supports more important features than xorriso – schily Feb 21 at 11:31
  • I searched for a possibility to create a bootable UEFI ISO image and everytime when I found something they were using xorriso that's why I'm using it :) – potter Feb 25 at 7:14
  • This may be a result of the unmaintained Linux man page web servers that never update information and for this reason only list features that have been part of 20+ year old versions. Look here schilytools.sourceforge.net/man/man8/mkisofs.8.html for a recent man page. – schily Mar 5 at 11:34
0

(If you have more questions, please mail to bug-xorriso@gnu.org. stackexchange blocks my browser because Google Captcha wants a newer one.)

The option you look for is --stdio_sync which is set to "on" by default. But since xorriso-1.3.8 the -as mkisofs emulation changes this default to "off". "on" causes a disk flush after each 16 MiB. You may choose a smaller synchronization size by e.g. "1m". If input files and emerging ISO image are on the same slow disk and RAM is sparse, this may cause slowdown.

The long "thank you" time span happens for me only if the -o file already exists and thus gets a call of truncate(2). In this case, the final close(2) returns only after 15 seconds, obviously after the file's buffers are flushed to disk. So deleting "$ISOFILE" before the xorriso run shortens the run by this final flushing time.

| improve this answer | |
  • Thank you very much! Great explanation! Setting the --stdio_sync to "on" helped already ;) – potter Feb 25 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.