0

I've been trying to resolve an issue with my new high-resolution ACER KG271 2K LED monitor on my HP EliteBook laptop with an Intel graphics chipset.

I have two ACER KG271 monitors connected to a docking station via DP (display port). Monitor 1 is DP1-1, and monitor 2 is DP1-2.

During boot I'm unable to see the boot up screen output on anything but my laptop screen. Upon arriving at the login screen, both monitors are black with no signal, and I have to lift the laptop lid to login. I've created an autostart script (in KDE Plasma) that runs the necessary xrandr commands to create a mode for 2560x1440 at 60Hz, which is the mode that the screens function at. I then use my xrandr script to set the displays to the new mode. I also have an arandr script in ~/.screenlayout that is set to place the screens in the correct orientation and what have you.

This works okay, but as I stated it only works after I've logged in. A recent update has made it so that it's no longer working after login, and I have to manually re-run my xrandr.sh script to get the 2k monitors to switch from no signal black screens to working. I'm not sure if the order of operations is wrong and that's causing the two scripts to conflict, but I believe that's the case because my screens EDID parsing seems to detect 2560x1440 @75Hz but this modeline doesn't work. Which is why I have to manually create the @60Hz modeline and set the monitors to that.

I think arandr screenlayout script may be setting the monitors to the incorrect 2560x1440 modeline @ 75Hz instead of waiting for my autostart script to create the correct modeline.

I've done a ton of reading, hence the usage of scripts to set my monitors but I'm unable to find a decent resolution to my problem, no pun intended. I think that I need to get into the nitty gritty with my Xorg config files, but everything I've read seems outdated and it's a bit convoluted on how to do it exactly with my Intel i915 graphics card and ACER KG271 monitors. If anyone has the expertise or know how, I'll be indebted to you for the help. I'll post my scripts and Xorg.0.log file below.

Configs, Scripts, and Logs

Xorg.0.log

xrandr.sh

.screenlayout/script-by-arandr

monitor-edid-output

1 Answer 1

0

Admittedly not a KDE user myself, but I was using XFCE which also doesn’t have proper HiDPI support, and managed to achieve the desired effect by adjusting font DPI and then tweaking a ton of various settings (mostly UI widget sizes) to take care of things like menus, taskbar, window widgets/titlebars, etc. That is to say, you’ll need to resort to this only if the version of KDE you’re using doesn’t have HiDPI support... which I would be very much surprised if the latest release doesn’t... both Budgie and Gnome have very simple and effective scaling built right into the settings applet.

In any case, this post may be helpful, as it discusses the approach above, which IMHO is a lot simpler than messing with xranr and xorg config (looks sharper too, as xranr will jhst scale your output!). It also briefly goes over the low level xorg config/xrandr approach too, if you’d rather do that.

Scaling the desktop - kde

1
  • I appreciate the help but this doesn't fix my problem of the monitors not displaying anything until I use xrandr to create a working 2560x1440 @60Hz resolution and manually set them to it. After I've done that process, the display scaling is absolutely fine. That's why I think I need to figure out how to blacklist the incorrect resolutions and force the display to the correct resolution using the Xorg files. I just haven't found the right settings yet because my displays still won't come up until after login and some manual intervention.
    – wsmyth
    Feb 19, 2020 at 12:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .