I have installed Debain-9 in my newly bought HP - Probook 455 G6. But it doesnt show wifi connection.

lspci shows Network Controller : ... RTL8822BE ... WiFi adapter.

I followed instruction here and tried using apt install firmware-realtek and using .deb package.

But still its not shown. Should I use these kind of 3rd party package for this?

Spec : Debian-9 on SSD

Edit : after @GAD3R request for lspci -knn |grep Net -A3

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter [10ec:b822]
    Subsystem: Hewlett-Packard Company Realtek RTL8822BE 802.11ac 2 × 2 Wi-Fi + Bluetooth 4.2 Combo Adapter (MU-MIMO supported) [103c:831b]
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader [10ec:522a] (rev 01)
    Subsystem: Hewlett-Packard Company RTS522A PCI Express Card Reader [103c:85d9]

1 Answer 1


The RTL8822BE firmware has been added to the backports-ed firmware-realtek package (it is not available in the main package) .

You can install it after adding backports to your sources.list:

printf "deb http://ftp.de.debian.org/debian stretch-backports main non-free" \
> /etc/apt/sources.list.d/debian-backports.list

The install firmware-realtek package:

apt update
apt install -t stretch-backports linux-image-amd64
apt install -t stretch-backports firmware-realtek
  • still nothing. Its shown in windows. Feb 18, 2020 at 18:57
  • 1
    FATAL : Module r8822be not found in directory /lib/modules/4.9.0-12-amd64 Feb 18, 2020 at 19:20
  • 1
    @SachithMuhandiram Install the linux-image-amd64 from backports then reboot.
    – GAD3R
    Feb 18, 2020 at 19:38
  • I think it just killed my pc. Now it doesn't boot Feb 18, 2020 at 19:53
  • @SachithMuhandiram from the grub menu select Advanced option for debian the select debian with 4.9.0-12.
    – GAD3R
    Feb 18, 2020 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.