2

A few months ago, I installed Linux Mint 19.1 x64 on a system with a Supermicro X9SCM system board. The X9SCM has two integrated NICs:

Intel 82574L Gigabit Network Connection
Intel 82579LM Gigabit Network Connection (Lewisville)

The Intel 82574L Gigabit Network Connection has been issue free.

The Intel 82579LM Gigabit Network Connection (Lewisville) is using a Linux kernel bridge with NetworkManager disabled.

Approximately every six minutes, the Intel 82579LM Gigabit Network Connection (Lewisville) reported the following:

e1000e 0000:00:19.0 eno1: Detected Hardware Unit Hang:
    TDH                  <d2>
    TDT                  <43>
    next_to_use          <43>
    next_to_clean        <d1>
    buffer_info[next_to_clean]:
    time_stamp           <103d3f01c>
    next_to_watch        <d2>
    jiffies              <103d3f8e0>
    next_to_watch.status <0>
    MAC Status             <40080083>
    PHY Status             <796d>
    PHY 1000BASE-T Status  <3c00>
    PHY Extended Status    <3000>
    PCI Status             <10>
e1000e 0000:00:19.0 eno1: Reset adapter unexpectedly
br0: port 1(eno1) entered disabled state
e1000e: eno1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
br0: port 1(eno1) entered blocking state
br0: port 1(eno1) entered forwarding state

Various ethernet cables and switch ports were tried, but it changed nothing.

1 Answer 1

3

The Intel 82579LM Gigabit Network Connection (Lewisville) defaults to offloading enabled, and disabling offloading works around the issue.

Determine NIC device:

ip addr show
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br0 state UP group default qlen 1000

Determine whether offloading is enabled (on):

sudo ethtool -k eno1
tcp-segmentation-offload: on
generic-segmentation-offload: on

To test, temporarily (reset after every reboot) disable offloading:

sudo ethtool -K eno1 tso off
sudo ethtool -K eno1 gso off

The log entries for "Detected Hardware Unit Hang" and "Reset adapter unexpectedly" should cease.

To add a permanent configuration change with NetworkManager disabled:

sudo nano /etc/network/interfaces

Add the following:

post-up /sbin/ethtool -K eno1 tso off gso off

-> Ctrl + o -> Enter -> Ctrl + x

Restart the computer.

Determine whether offloading is disabled (off):

sudo ethtool -k eno1
tcp-segmentation-offload: off
generic-segmentation-offload: off

I spent several days troubleshooting this, and I hope it helps others.

---------- NetworkManager ----------

I only needed to disable offloading in this specific scenario with NetworkManager disabled and using a Linux kernel bridge for QEMU/KVM. Before I configured the bridge, I did not notice whether there was an issue with hangs and resets. If there is, you may be able to add the appropriate commands to a startup script to accomplish the same result while continuing to use NetworkManager. The following is untested:

sudo crontab -e

Press button "1" for nano.

On the last line enter the following:

@reboot sleep 10 && ethtool -K eno1 tso off
@reboot sleep 10 && ethtool -K eno1 gso off

sudo shutdown -r now

---------- lshw output ----------

*-network
     description: Ethernet interface
     product: 82579LM Gigabit Network Connection (Lewisville)
     vendor: Intel Corporation
     physical id: 19
     bus info: pci@0000:00:19.0
     logical name: eno1
     version: 05
     serial: <REMOVED>
     size: 1Gbit/s
     capacity: 1Gbit/s
     width: 32 bits
     clock: 33MHz
     capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
     configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.13-4 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
     resources: irq:30 memory:df900000-df91ffff memory:df925000-df925fff ioport:f020(size=32)
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.