7

My Fedora 17 installation is no longer booting into X : it finished loading the boot screen, then the cursor turns into an "X", flashes a quickly a few times then the just stalls.

To get X to load, I have to log into a terminal, kill the Xorg process and run it manually using startx, at which point it all works fine.

I thought it might have been an issue with the Plymouth service, as described in another post here: Fedora 17 freezes on boot, but disabling the plymouth service like this:

systemctl mask plymouth-start.service

had not effect.

Oddly, in my /var/log directory, there are 6 Xorg log files created at every boot (named Xorg.0.log --> Xorg.5.log). Is this normal? Are 6 Xorg servers trying to start? The #1 to #5 log files all have the same error message in them:

[ 21.665] (EE) Screen(s) found, but none have a usable configuration.

I have tried reinstalling my graphics driver (gallium driver for AMD 3450 HD card) as well as uninstalling and reinstalling plymouth.

Xorg obviously works as I can start it from the command line, but why does it fail to start from booting?

Any help would be very much appreciated!

2
  • 1
    Never did get to the bottom of this one. Have upgraded to Fedora 18 now and that has fixed it.
    – ccbunney
    Jan 26, 2013 at 0:24
  • 1
    To answer part of your question, the fact that there are more xorg.x.log files is perfectly normal and it has nothing to do with the number of X processes. It has to do with something called log rotation.
    – schaiba
    Sep 1, 2013 at 12:52

1 Answer 1

1

The error message says all: X finds a screen, but has no way of configuring it sanely. Have you perchance added an xorg.conf file or fiddled around with something such (modern versions of X don't use it)? Care to post the full contents of the Xorg.?.log files? It is weird that starting it by hand does work.

(In any case, it is probably more fruitful to take a look at Bugzilla and report the trouble there, those folks are in much better pòsition to help you than we).

2
  • 1
    no I did not change my xorg file (not intially anyhow). In fact, there was not even a xorg.conf file - like you say, its not needed anymore. Anyhow - after a few months of not getting anywhere with this, I recently upgraded to Fedora 18 and now everything is working again. Nice.
    – ccbunney
    Jan 26, 2013 at 0:24
  • @KernowBunney, i agree that xorg.conf is not needed anymore to start xserver, but i solved my similar issue by creating one. i have and intel 945G. i also added screen resolution there.
    – milevyo
    Feb 25, 2016 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .