System- core i7 4790, nvidia GTX 970, 16gb RAM, ubuntu linux.

Prior to an update everything was fine. After running a software update my distro shows itself as being version 20.04 although I didn't specifically ask for that, (lsb_release -d: "Description: Ubuntu Focal Fossa (development branch")

I saw my cpu periodically spiking even doing nothing, and using 'top' found the guilty processes were Xorg, "nv_queue". Disabling the nvidia driver (going back to an opensource driver) removed this spiking, but obviously leaves me unable to fully use the video card.

I tried going back driver versions - but could only go back as far as version 390, and the problem still happened.

Does anyone know if this is a broad problem with the development branch or something. I'm about to try doing a fresh install on another drive (I guess it might specifically be the interaction of the driver and something specific to the latest linux install). Maybe there are settings that can be tweaked to alleviate it? I've seen alot of talk of stuttering with nvidia drivers elsewhere (referencing earlier versions of the driver and ubuntu)

  • Try a fresh install, then another distro with an older kernel. – Vascon63 Feb 17 '20 at 23:57
  • I would go and search the Ubuntu bugtracker for similar problems. If you can't find anything there I'd check upstream, at the nvidia driver, whether there are any reports (and bandaids, fixes, new releases etc.) – Tomáš Pospíšek Feb 18 '20 at 0:34
  • EDIT: seems 18.04 runs fine. I will stick with that and just run the latest versions experimentally on a spare drive to check. Reading around I've seen earlier reports of similar problems and various bandaids but couldn't find anything specific. It might be the specific card (970 had other famous issues..) – centaurian_slug Feb 18 '20 at 20:38

Please test with PulseAudio disabled ( pulseaudio -k ) and see if video still stutters.

Killing and later restarting PA results in temporary resolution to the stuttering issue.

( Using Bluetooth headset, iMac 2013 27", GT755M GPU, Ubuntu 19.10 and 20.04 )

EDIT: On ubuntu, try also remove the speech-dispatcher-audio-plugins package which has been indicated in a couple of instances as being the key cause of why PA causes the stuttering with the nVidia drivers. ( Since removing the package there has been no repeat of the original issue )

UPDATE: Been 5 days now, still no stuttering. Definitely has fixed the fault for me. Hope this helps some others.

  • Killing and letting pulseaudio restart certainly seems to be a temporary solution but only for a short time, maybe about 5-10 minutes. What seems to help is disabling WiFi. Have you been able to do some additional testing? I'm on 20.04 both my desktop and laptop suffering from this issue (both also have nvidia cards) – wax911 May 22 '20 at 17:59

Just ran into a similar issue on Debian 10.8 with an RTX 3060 after moving my machine, leading to my finding this report. Prior to the move, there was no problem. After the move, display started stuttering while running a game, but operation of display was otherwise fine. System monitor showed the Xorg processes taking relatively huge amounts of cpu compared to usage noted prior to move. Tailing /var/log/messages revealed repeating messages about the display device connecting. Shut the machine down and re-seated the hdmi connection at the video card. Poof - problem went away. I don't expect that everyone with this symptom has the same problem, but this is the easiest thing to try - I do the easiest things first :-) . I don't know if there is a better place to post this, will look further later, when I have more time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.