1

Earlier today I was upgrading my computer from Ubuntu 19.04 to 19.10. The update temporarily broke my computer, booting into GRUB safe mode. With the accepted answer from grub error: you need to load kernel first I was able to load the kernel, specifically the following snippet:

insmod linux linux /vmlinuz root=/dev/sda2 initrd /initrd.img boot

That allowed me to load into my OS, and I used the solution proposed in Login loop on Ubuntu 19.10 to help me finish updating. Now, my computer works fine, but I still need to input the code that to which I referred earlier. How can I have it so that it will automatically boot into my Ubuntu kernel?

EDIT: Thankfully solved by the comments below.

  • 1
    Have you tried sudo update-grub to update your /boot/grub/grub.cfg? – Freddy Feb 17 at 17:36
  • I'm getting /usr/sbin/grub-probe: error: failed to get canonical path of 'dev/sda2'. right now. – connordaniel Feb 17 at 17:40
  • 1
    That sounds really broken. Can you try a reinstall with sudo grub-install /dev/sda (assuming /dev/sda is the target drive) followed by sudo update-grub? – Freddy Feb 17 at 17:53
  • That did it! Thank you so much for your help. – connordaniel Feb 17 at 18:37
  • Would you mind to write a short self-answer to your question? Comments can be deleted and are not a reliable source. Thank you! – Freddy Feb 17 at 18:42
1

I solved the problem using Freddy's comments, specifically sudo grub-install /dev/sda and then sudo update-grub.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.