I'm trying to debug issues with wifi connectivity of my RPi 3 (it just randomly loses connection sometimes). And I noticed that

ps aux | grep wpa_supplicant gives me:

root       310  0.0  0.4  10708  3636 ?        Ss   lut16   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
root       397  0.0  0.4  11080  3140 ?        Ss   lut16   0:01 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext

I'm using a minimal Raspbian Buster and the only thing that I've done is that I configured the /etc/wpa_supplicant/wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


Is it normal?

If yes - then why there are two instances of wpa_supplicant?

If no - how to get rid of one?

1 Answer 1


there are two instances of wpa_supplicant?

The first command is called by the wpa_supplicant.service,see :

systemctl cat wpa_supplicant.service

The second one is executed manually:

wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext

Multiple wpa_supplicant instances to configure the same network interface may conflict, to stop them, run:

killall wpa_supplicant


killall wpasupplicant

Then cleanly start a new instance manually.

  • 3
    I dug into it deeper, and it looks like the first one comes from the wpa_supplicant service, and the second one is being run by the dhcpcd service (the code for this seems to be in the /lib/dhcpcd/dhcpcd-hooks/10-wpa_supplicant . I disabled the wpa_supplicant service, let's see if it'll help with my connection issues. Thanks! Feb 17, 2020 at 16:15
  • @ŁukaszZaroda, did disabling wpa_supplicant.service solve your connection issues?
    – canochordo
    Apr 25, 2021 at 8:00
  • @canochordo Disabling the wpa_supplicant doesn't solve the issue. You need to kill the running instance.
    – GAD3R
    Apr 25, 2021 at 13:36
  • For those who want to try this sudo systemctl disable wpa_supplicant.service Aug 8 at 18:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .