0

I'm using Cinnamon on Debian 10 through virtualbox, and the "Mouse and Touchpad" settings don't seem to let me configure a 3 finger touchpad tap as the middle mouse button.

How else can I do this?

2

To enable triple-finger tap , edit the configuration file under /etc/X11/xorg.conf.d:

sudo nano /etc/X11/xorg.conf.d/40-libinput.conf

As follows:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        #MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "on"
        Option "TappingButtonMap" "lmr"
EndSection

Documented on Arch-linux wiki: Button re-mapping

Swapping two- and three-finger tap for a touchpad is a straight forward example. Instead of the default three-finger tap for pasting you can configure two-finger tap pasting by setting the TappingButtonMap option in your Xorg configuration file. To set 1/2/3-finger taps to left/right/middle set TappingButtonMap to lrm, for left/middle/right set it to lmr.

Section "InputClass"
     Identifier "touchpad"
     Driver "libinput"
     MatchIsTouchpad "on"
     Option "Tapping" "on"
     Option "TappingButtonMap" "lmr"
 EndSection

NB: Remember to remove MatchIsTouchpad "on" if your device is not a touchpad and adjust the Identifier accordingly.

3
  • Well this is strange, but your text didn't work at first, so I deleted the uncommented MatchIsTouchpad and it worked. Then, because I wanted to fool around with it to understand how things worked, I changed the "lmr" to "lrm", but that didn't actually swap them for whatever reason. I then decided to change it back to "lmr", but it didn't change back to how it was working. Now I'm back to where I started, even with the edits I made to make it work previously. I'm super confused. – Otherness Feb 18 '20 at 5:28
  • @Otherness Log out then login after modifying the configuration file. – GAD3R Feb 18 '20 at 10:17
  • Unfortunately that still doesn't do anything. Could it be that I'm changing the wrong configuration file perhaps? – Otherness Mar 12 '20 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.