0

Two days ago I did a system update with

sudo pacman -Syyu

Unfortunately, my battery was empty and my laptop turned off during the System update. When I tried to start Arch Linux again, I was stuck on the grub Bootloader with the following message:

Error: file /vmlinux-linux-lts not found. Error: you need to load the kernel first Press a key to continue

According to https://bbs.archlinux.org/viewtopic.php?id=238904 , I have to reinstall linux again so I did the following:

  1. Installed an Arch Linux iso on a USB-stick
  2. Checked my partitions with fdisk -l
  3. Mounted my root partition with mount /dev/sda1 /mnt (I don`t have a boot partiton)
  4. Installed mkinitcpio, linux. linux-lts and systemd with sudo pacman -S linux linux-lts mkinitcpio systemd
  5. Typed exit and rebooted.

As you can see, I forgot to umount my root partiton.

When I rebooted the system, I could finally boot into arch without the error messages but I run into the next problem. I was stuck at the boot screen with the message:

Starting Version 244.3-1-arch
/dev/sda1: recovering Journal
/dev/sda1: clean, 712088/5898240 files, 15789063/23592960 blocks

After a while, I switched to tty2 by pressing Ctrl+strg+F2. I did some research on the Internet and I found a solution how to escape from this:

On the grub menu, I selected Arch Linux and pressed e. In the line

linux /boot/vmlinuz-linux-lts root=UUID=168b8466-66a9-4da7-bld4-07f5e95d1c73 rw loglevel=3 quiet

I removed quiet and booted into arch. Now I am stuck at Reached target Graphical Interface.

For any reason, sddm does not want to start. If I switch to tty2, I always get prompted into a zsh shell.

I tried everything, from removing ./Xauthority to reinstalling the xorg package. Nothing worked.

Additional Information:

Laptop name: HP625

processor: AMD Athlon II P320

GPU: ATI Radeon HD 4250

dual-boot system (Arch Linux alongside with Kali Linux)

Related links: Arch Linux stuck at boot (reached target Graphical Interface) https://bbs.archlinux.org/viewtopic.php?id=228814 https://wiki.archlinux.org/index.php/Xorg https://wiki.archlinux.org/index.php/SDDM https://wiki.archlinux.org/index.php/LightDM https://github.com/sddm/sddm/issues/352

1 Answer 1

0

When you mounted your harddrive, did you chroot into your disk? If not, running those pacman commands would be updating the packages on the usb installation, not the harddrive.

3
  • Yes I chrooted into the Disk. Forgot to mention it.
    – antimatter
    Feb 15, 2020 at 13:22
  • How about running a pacman -Syuu from inside the chroot? Seems to me that there is no way to know that only those four packages had issues. If that does not work, you could take the nuclear option of reinstalling all packages with pacman -Qnq | pacman -S - but definitely try the update first.
    – bisen2
    Feb 15, 2020 at 13:29
  • I tried pacman -Syyu inside chroot but it does not help.
    – antimatter
    Feb 19, 2020 at 14:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .