3

I have the following partition structure

/dev/loop0 squashfs
/dev/sda1  system reserved ( ntfs )
/dev/sda2  ntfs ( windows partition )
/dev/sda3  ntfs 
/dev/sda5  ntfs
/dev/sda6  ext4

I have Ubuntu installed inside windows. I formatted /dev/sda6 from inside Ubuntu ( using Gparted ). What I totally forgot was /dev/sda6 had Fedora which was the root directory of GRUB. Now how do I recover grub. I have tried chrooting to the ubuntu partition and installing grub. But the boot fails with, " No such device... ". And I cannot install elementaryOS on /dev/sda6 since the installer doesn't go beyond a couple of windows.

2
  • 1
    Which version? There are several versions of GRUB, which are incompatible with each other.
    – Mr Lister
    Nov 26, 2012 at 15:39
  • Does the Ubuntu installer you used have a rescue mode that just does a grub reinstall?
    – jw013
    Nov 26, 2012 at 18:33

2 Answers 2

1

In OpenSuse, this problem could be solved by doing a recovery installation. This reinstalls all programs which are delivered with the installer, including Grub. As all Ubuntu installers I have ever used had Grub included, I guess this will also works for you, but as I am not eager to duplicate your problem, it isn't guaranteed that Grub will succesfull be installed.

1

Best option is to use SuperGrub from http://www.supergrubdisk.org/ Download the iso burn to pen drive or cd and boot into live mode. Follow the onscreen GUI instructions to reinstall and fix the grub.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .