I'm trying to set up a dualboot Win8/Linux on my HP tablet (touchsmart tm2-1050ez). However, when I'm finished setting it all up, after a few more reboots, I'm not able to boot to Linux anymore, as I keep getting the error

BUG: soft lockup - CPU#0 stuck for 23s! [swapper/0:1]

over and over again right after GRUB. I've left it sit for an hour, only to retrieve a screenful of these messages (only varying slightly in the time it's been stuck). Even recovery mode won't work.

So far I've tried Fedora 17, Ubuntu 12.10 and most recently Mint MATE 14, all of which have died in this exact fashion within a day of the original setup.

I've googled the problem, but all I could come up with was to run a BIOS update, which I already did and didn't help anything.

Help would be much appreciated.

  • 1
    Have you tried completing the installation without installing any updates? The attempt here is to determine whether the problem is with the base system or an update. Nov 26, 2012 at 15:02
  • 2
    Probably a kernel bug, or bad ACPI tables. Unfortunately not the kind of things you can repair without solid expertise, you may be reduced to waiting for a kernel or firmware upgrade. Nov 26, 2012 at 23:43
  • 1
    (1) When that happen, on the next reboot to linux, try edit the grub line and add "acpi=off", see if that helps at all. (2) Can you boot into windows right after that CPU error?
    – John Siu
    Dec 14, 2012 at 22:09
  • 1
    That is the kind of thing that I have seen caused by a bad stick of RAM, but in your case that is not likely. Sounds like you shouldn't be doing this unless you can find someone else with the same device as you that is doing the same thing. Otherwise, its just guessing.
    – djangofan
    Jan 2, 2013 at 17:34
  • 1
    Have you disabled FastBoot in Windows 8? If you didn't, your UEFI partition gets locked (except if you restart windows 8, shutdown still doesn't unmount it) and that might result in your Linux not booting. askubuntu.com/questions/452071/…
    – Alko
    Oct 18, 2014 at 14:20

3 Answers 3


Please add acpi=off noapic to your boot parameters. It will disable any ACPI functions (that is the system that controls your dynamic speed fans, the power button behavior, sleep states, etc.). This verifies if your problem is related to energy functions.


Edit Grub-Boot-Line and append to kernel-line:

coldplug DRV_DEBUG=verbose

to get information about when getting stuck (which module(s) loaded just before stuck).


This has happened to me before. I was trying to install Linux on my Acer x64 bit laptop and I ran into those same issues. I didn't want to install, Ubuntu for Netbooks or install the Tablet version, wanted the actual Linux on my system. I honestly think installing regular Ubuntu or Fedora is too robust for tablet hardware and it isn't tested well on those machines since it's not too robust, especially the CPU and motherboard architecture is different although it says its x64 bit compatible.

Try looking at this distro:


Puppy linux is lighter and you get full command line access.

Also take a look at this before you download the .iso file


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .