0

So my lenovo ideapad s340 runs linux mint 19.3 cinnamon 64-bit 5.3.0-28-generic. (Laptop is 3 days old, came with no OS [just BIOS] and I installed mint at first boot up).

GPU is Intel UHD 620 (No Nvidia), driver manager shows no Intel drivers, it only shows a blank screen and says "no proprietary drivers are in use".

and my laptop does not recognize the HDMI port even exists (when I run xrandr it does not appear there) and display settings only show the laptop's main monitor, despite having a fully functioning monitor properly plugged in the HDMI port (Tried 3 monitors, Including 1 TV) and the monitor only shows "No signal"

aplay -l output:

**** List of PLAYBACK Hardware Devices ****

card 0: PCH [HDA Intel PCH], device 0: ALC257 Analog [ALC257 Analog]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]

Subdevices: 1/1

Subdevice #0: subdevice #0

xrandr output:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384

eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 
344mm x 194mm
1920x1080     59.98 +  59.97*   59.96    59.93  
1680x1050     59.95    59.88  
1600x1024     60.17  
1400x1050     59.98  
1600x900      59.99    59.94    59.95    59.82  
1280x1024     60.02  
1440x900      59.89  
1400x900      59.96    59.88  
1280x960      60.00  
1440x810      60.00    59.97  
1368x768      59.88    59.85  
1360x768      59.80    59.96  
1280x800      59.99    59.97    59.81    59.91  
1152x864      60.00  
1280x720      60.00    59.99    59.86    59.74  
1024x768      60.04    60.00  
960x720       60.00  
928x696       60.05  
896x672       60.01  
1024x576      59.95    59.96    59.90    59.82  
960x600       59.93    60.00  
960x540       59.96    59.99    59.63    59.82  
800x600       60.00    60.32    56.25  
840x525       60.01    59.88  
864x486       59.92    59.57  
800x512       60.17  
700x525       59.98  
800x450       59.95    59.82  
640x512       60.02  
720x450       59.89  
700x450       59.96    59.88  
640x480       60.00    59.94  
720x405       59.51    58.99  
684x384       59.88    59.85  
680x384       59.80    59.96  
640x400       59.88    59.98  
576x432       60.06  
640x360       59.86    59.83    59.84    59.32  
512x384       60.00  
512x288       60.00    59.92  
480x270       59.63    59.82  
400x300       60.32    56.34  
432x243       59.92    59.57  
320x240       60.05  
360x202       59.51    59.13  
320x180       59.84    59.32  
DP-1 disconnected (normal left inverted right x axis y axis)
0

Try changing the boot mode from legacy mode to UEFI in BIOS. You access the BIOS by pressing F2 when booting.

1
  • Tried this and it solved the problem Feb 21 '20 at 15:58
0

Solution:

The command

sudo strings /sys/firmware/acpi/tables/DSDT | grep -i 'windows ' | sort

listed several windows options, latest was "Windows 2018" So I edited the grub menu with the command

xed admin:///etc/default/grub

Went to the line :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and added

acpi_osi=! \"acpi_osi=Windows 2018\" ,

changing the line to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! \"acpi_osi=Windows 2018\""

after that I ran "sudo update-grub" and rebooted the computer.

then I went to BIOS and changed the setting "Boot Mode" from "Legacy Support" to "UEFI" and now it works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.