1

When I run tmux, every character has a boxed '?' next to it. The boxed '?' symbols also appear after every character I type when I am within vim when I am in tmux. I have been doing research online about how to alter my ~/.vimrc and ~/.bashrc files but am having a difficult time finding the exact solution to my question. Nothing I have added to ~/.tmux.conf has seemed to do anything so I no longer have any code there.

I am running an Ubuntu bash shell on a Windows 10 operating system. To clarify, I am running Ubuntu as a graphic application using the Windows subsystem. I am not emulating it.

Here is what my hello.cpp file looks like when I try to insert any code in to it. This happens when I try to write a hello.java file as well. Does anyone have any insight?

enter image description here

.vimrc:

:set backspace=ident,eol,start

syntax on
:hightlight Comment ctermfg=23

My additions to .bashrc:

echo "Welcome back"

cd ~/../../mnt/c

alias tmux="TERM=screen-256color-bce tmux"

...
(default code)
4
  • Are you typing soma particular character when the boxes appear, like tab?
    – Kusalananda
    Feb 13, 2020 at 7:29
  • CMD and PowerShell are not terminal emulators. The terminal emulator would be something like Windows Terminal. jdebp.uk./FGA/a-command-interpreter-is-not-a-console.html
    – JdeBP
    Feb 13, 2020 at 11:11
  • No, it can be any character. Feb 13, 2020 at 17:37
  • Have you tried changing the font in your terminal? Check if it works with DejaVu Sans Mono for instance.
    – undercat
    Feb 13, 2020 at 17:46

1 Answer 1

4

I strongly suspect this is a problem with your terminal rather than any application (tmux, bash, vim). A guess would be it is sending UTF-16 for key presses instead of UTF-8. I suggest you try a different terminal (putty?) and if the problem goes away then report this to the developers of your terminal. You might have luck poking about in the settings for the terminal looking for keyboard options.

Also, you should not use TERM of screen outside tmux - use whatever is right for your terminal (often xterm even in terminals that aren't xterm). Use screen or tmux inside tmux. But I don't think this is related to your problem.

2
  • I don't know how I would use another terminal considering that I am not emulating Ubuntu, I am running it as a graphic application using the windows subsystem. Feb 13, 2020 at 17:17
  • 1
    @DarienSpringer You can run sshd and then choose localhost as the host name in Putty. See details here for instance.
    – undercat
    Feb 13, 2020 at 17:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .