0

It seems that my Lenovo laptop is not totally compatible with Linux. Let me explain:

Five months ago I bought a Lenovo ThinkPad T490 (i7-8565U, NVIDIA GeForce MX250 (and, of course, the Intel UHD 620), 24 GB RAM, 1TB SSD) without OS as I had planned to install Linux on it. Because I like Mint with KDE I decided to install the latest version of that, I believe it was Mint 18.3, as KDE is not supported any more on later versions. I had been using that OS and desktop environment on my previous laptop (also a ThinkPad but model T440s) for quite some time with no problems at all. Therefore I was surprised to see that I could not install it. The live stick worked, but the installation process was interrupted somewhere at the end, where the installer said that GRUB was missing or corrupted (or something similar). After trying to install other KDE OSes, i.e. Kubuntu and Neon, without success, I managed to install the newest Mint 19.2 Mate.

This worked, but barely. The screen flickers a lot and only stops when I switch the graphics driver from Intel to nvidia or the opposite. Also the fan is ON almost permanently, without heavy graphical work, not even a film. Some icons and bars are also not integrated very well or shifted.

Now, when I wanted to install a new OS, not even that would work any more. It was not even possible to properly boot into the live OS from the USB stick (I tried Kubuntu, Ubuntu, Mint KDE, Neon, Debian and Fedora with and without KDE). The boot process always froze, sometimes just when the home screen was showing. The only working live OS was the one, that I had used to install my current system (Mint Mate). I also created live sticks with LiLi on Windows, however, nothing changed.

I have heard of processor problems on this model with Linux, however, I cannot say that I have experienced that. I have been thinking about installing Windows on it an resell it, but I am also not sure that this is going to work.

Google could not help me until now. It seems that I am the only one with this problem... which is not very reassuring. My preferred solution would be to setup a fresh and well working installation with my favourite Linux. But I am open to alternatives.

Has anyone an idea how to solve this problem?

I'd be glad for any help.

EDIT: Lenovo support assumes it's a hardware problem. So, it's not really solved but it's Lenovo's turn now to try and fix the problem.

  • The T490 is a quite recent machine. I wouldn't expect any Linux release from 2018 to work well on it. You likely need a recent kernel and Nvidia driver. Currently running Kubuntu 19.10 without problems on an even more recent Lenovo P53... – xenoid Feb 12 at 21:46
  • Make sure you have updated to the latest BIOS (N2IUJ18W 1.60/1.08, released 23 Jan 2020. – Freddy Feb 12 at 22:20
  • This web page might be of some help. wiki.archlinux.org/index.php/Lenovo_ThinkPad_T490 – Michael Prokopec Feb 12 at 22:41
  • @Freddy: I have tried to update the BIOS for two days now, following this description: [cyberciti.biz/faq/update-lenovo-bios-from-linux-usb-stick-pen/]. However, when I switch into the boot setup menu and choose the 'USB HDD ...' option (the only one which is not ubuntu or my harddrive (except for PXE boot)), the screen just turns black for a few seconds and then goes back to the boot setup menu screen, with nothing changed. I repeated this process several times, with no success. The BIOS/UEFI setup is set to use 'both' but uses UEFI first, does this matter? – cain Feb 15 at 10:28
  • @cain Mode 'both' with 'UEFI first' should be fine (UEFI must be enabled and secure boot disabled). Also make sure that flashing the BIOS is allowed (option Security->UEFI BIOS Update Option on my T440s). You could also try to load the iso via grub2. – Freddy Feb 15 at 22:19
0

Try booting in "basic graphic mode" (it is called something like that in Fedora), check if you can boot into text-only mode (add "3" at the end of the grub line for the kernel, if you can get into that).

Best bet is jut to grab a fresh copy and write it again. Also check you are able to boot that way on that machine, might need some setup.

| improve this answer | |
  • Until now I haven't managed to boot into anything else than the OS that I have already installed. Every time I try, the screen goes black for a few seconds and goes back to the boot screen or it freezes after telling me: 'CPU_: Package temperature above threshold, cpu clock throttled' followed by '[Firmware Bug]: TPM interrupt not working, polling inst' and 'iqr 31: nobody cared (try booting with "irqpoll" option)' and finishing with 'Disabling IRQ #31'. After this, the screen freezes and I have to reboot with the start button. I have no idea what this could mean... do you have an idea? – cain Feb 22 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.