4

I run a dual boot Pop!_OS/Windows setup and I'm migrating (for the first time) to Linux. I've spent about a month in Linux and very much like the experience and want to continue using it.

However I have a gaming motherboard from Gigabyte with a built in wifi/BT adapter. For some reason, Windows sees the wifi normally, but my Pop_OS! distro doesn't. And even stranger is that it sees the Bluetooth feature although it's connected to the same external antenna on my desk.

Before asking why this is happening or how to fix it, how do I gather information to understand the problem? I'm very new to Linux so please bear with me when I don't know the jargon used in this environment.

2 Answers 2

5

First, you'll need to accurately identify the WiFi chip used.

Most built-in adapters on motherboards generally connect to the PCIe bus on the WiFi side, and to the USB bus on the Bluetooth side. So, you should run lspci -nn and find the line referring to your WiFi adapter: the hex numbers in square brackets like [xxxx:yyyy] can be very useful in identifying the WiFi chip, if the name displayed by the lspci command is not descriptive enough.

The first part if the [xxxx:yyyy] is a vendor ID, and the second is a product ID assigned by that particular vendor. You can use the numbers to look up the device in the PCI ID Repository: this might be helpful if the distribution's list of PCI IDs and corresponding human-readable names is not up to date enough to fully identify the WiFI adapter chip.

Once you know the name of the WiFi chip vendor, you can go to https://wireless.wiki.kernel.org/en/users/drivers and find out about any relevant drivers. By looking at vendor and bus type, you can usually limit it to just a few possible drivers, then it's time to read the information pages of those drivers and see if your WiFi chip is supported by the driver.

If you find a driver that supports your WiFi chip, the next question is "is that driver module already present on your system?" You can use the lsmod command to list all the currently-loaded kernel modules, and sudo modinfo <name-of-module> to see if a module exists but is not getting automatically loaded for some reason. You can also run sudo dmesg -H to view the kernel message buffer: if something has gone wrong in hardware detection, you might see more information about the problem in there.

The problem might be that your WiFi chip needs firmware, which is not allowed to be redistributed by anyone other than the chip vendor. In that case, the driver information page at wireless.wiki.kernel.org will have information on how to download and extract the necessary firmware from a package downloadable from the vendor's website, and how to place the extracted firmware file to proper location so that the driver will find it (normally somewhere under /lib/firmware).

2
  • This is a very interesting thread. I’m in the same boat and have found that recently (after installing a separate SSD running windows - with the pop SSD physically removed during installation per recommendations) this issue began plaguing my machine. I can’t figure out what is causing it or how to fix it. Booting into windows and back to pop sorted it out but that was just during usage not a dedicated effort to reset it. Any ideas?
    – vampiire
    Jul 16, 2021 at 0:32
  • @vampiire Please make your own question post and provide in it any information of the WiFi adapter model as I suggested in my answer here, e.g. the relevant lspci -nn and/or lsusb listing line(s) at least. The original poster of this question seems to have abandoned it.
    – telcoM
    Aug 4, 2021 at 10:05
4

For anybody having the same Problem while dual booting windows/linux:

If you have a dual-boot machine with a recent version of Windows and start seeing problems during initialization of the WiFi device when booting Linux, the problem could be due to the “fast startup” feature on Windows.

With this feature enabled, Windows don't really shut down the entire system, but leaves things partially running so you can start the machine faster again. Try to disable this option, on Windows 10 it should be in “Control Panel→Hardware and Sound→Power Options→System Settings”. Select “Chooose what the power buttons do” to access the System Settings from the Power Options. Then disable the “Fast Startup” option in “Shutdown Settings”. This will cause Windows to fully shutdown and may solve the issue.

from https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

This is what fixed it for me.

3
  • This did it for me, never had a problem before, but guess Windows changed something recently that started breaking it! Jan 31, 2022 at 18:54
  • Apparently windows only does this if you do a regular shutdown. If you use restart to switch to Linux the problem shouldn't occur. Maybe that is what you had been doing.
    – micha
    Feb 28, 2022 at 23:56
  • Brilliant! That did it for me. How did you figure this out?
    – Longblog
    May 21, 2022 at 20:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .