1

I'm running KDE Plasma desktop in Arch Linux.

In GTK-based applications, when I use the Ctrl-arrow shortcut to move a text cursor around words, it stops on underscore characters. e.g. If I am in a "Save File" dialog in GTK and my cursor is at the end of this_character_sequence, pressing Ctrl-<Left> will move the cursor to the left of the s in sequence.

In KDE (for example, Dolphin or any KDE save file dialog), doing the same thing would move the cursor to the very beginning of the sequence, as the _ is not interpreted as a break between words.

Is this behavior configurable anywhere? I would like my KDE applications to interpret the _ character as a word break. I've looked around the (extensive) KDE settings, and cannot find anything related.

2
  • 1
    I've been annoyed by this for years as well. Apparently there was a bug report about this in 2020-01-08 which indicates that this cannot be adjusted yet.
    – Carolus
    Jan 28, 2021 at 20:27
  • 1
    Hey, thanks for pointing that out. I've added a comment to the bug report as well.
    – jat255
    Jan 28, 2021 at 23:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.