0

When I run sudo apt install wine-stable on Pop!_OS 19.10 I get the following error

Err:1 http://us.archive.ubuntu.com/ubuntu eoan-updates/main i386 libblkid1 i386 2.34-0.1ubuntu2.1
  404  Not Found [IP: 91.189.91.23 80]
Err:2 http://us.archive.ubuntu.com/ubuntu eoan-updates/main i386 libmount1 i386 2.34-0.1ubuntu2.1
  404  Not Found [IP: 91.189.91.23 80]
Err:3 http://us.archive.ubuntu.com/ubuntu eoan-updates/main i386 libuuid1 i386 2.34-0.1ubuntu2.1
  404  Not Found [IP: 91.189.91.23 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/u/util-linux/libblkid1_2.34-0.1ubuntu2.1_i386.deb  404  Not Found [IP: 91.189.91.23 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/u/util-linux/libmount1_2.34-0.1ubuntu2.1_i386.deb  404  Not Found [IP: 91.189.91.23 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/u/util-linux/libuuid1_2.34-0.1ubuntu2.1_i386.deb  404  Not Found [IP: 91.189.91.23 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

This is my sources.list file

# deb cdrom:[Pop_OS 19.10 _Eoan Ermine_ - Release amd64 (20200131)]/ eoan main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ eoan main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ eoan-security main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ eoan-security main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ eoan-updates main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ eoan-updates main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ eoan-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ eoan-backports main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu/ eoan main restricted universe multiverse
deb http://apt.pop-os.org/proprietary eoan main
# deb-src http://apt.pop-os.org/proprietary eoan main

This is the result of running sudo apt update

Hit:1 http://ppa.launchpad.net/kritalime/ppa/ubuntu eoan InRelease
Hit:2 http://ppa.launchpad.net/libratbag-piper/piper-libratbag-git/ubuntu eoan InRelease
Hit:3 http://ppa.launchpad.net/system76/pop/ubuntu eoan InRelease                                     
Hit:4 https://dl.winehq.org/wine-builds/ubuntu eoan InRelease                                         
Ign:5 http://repo.vivaldi.com/stable/deb stable InRelease                                             
Hit:6 http://repo.vivaldi.com/stable/deb stable Release                                               
Hit:7 http://us.archive.ubuntu.com/ubuntu eoan InRelease                                          
Get:8 http://us.archive.ubuntu.com/ubuntu eoan-security InRelease [97.5 kB]
Hit:9 http://apt.pop-os.org/proprietary eoan InRelease   
Get:11 http://us.archive.ubuntu.com/ubuntu eoan-updates InRelease [97.5 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu eoan-backports InRelease [88.8 kB]
Fetched 284 kB in 1s (251 kB/s)     
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up-to-date.

EDIT 2 And this is the result of apt policy wine-stable libblkid1:

wine-stable:
  Installed: (none)
  Candidate: 5.0.0~eoan
  Version table:
     5.0.0~eoan 500
        500 https://dl.winehq.org/wine-builds/ubuntu eoan/main amd64 Packages
     4.0.3~eoan 500
        500 https://dl.winehq.org/wine-builds/ubuntu eoan/main amd64 Packages
     3.0.1ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu eoan/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu eoan/universe i386 Packages
libblkid1:
  Installed: 2.34-0.1ubuntu2.1
  Candidate: 2.34-0.1ubuntu2.1
  Version table:
 *** 2.34-0.1ubuntu2.1 500
        500 http://us.archive.ubuntu.com/ubuntu eoan-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.34-0.1ubuntu2 500
        500 http://us.archive.ubuntu.com/ubuntu eoan/main amd64 Packages

Can anyone advise on how I might fix this? Many thanks!

0

Your package index is outdated as the error message suggests.

Try again with

sudo apt update
sudo apt install wine-stable
6
  • Thanks for the reply. Sadly, this doesn't fix it. I've added the result of sudo apt update to the question.. Feb 9 '20 at 13:16
  • Did you get the same error? After the update apt should now be aware that e.g. libblkid1_2.34-0.1ubuntu2.1_i386.deb was replaced by libblkid1_2.34-0.1ubuntu2.2_i386.deb. Please try sudo apt update --fix-missing followed by sudo apt install -f to fix the errors first and post the output if that fails.
    – Freddy
    Feb 9 '20 at 15:21
  • I ran both of these with no errors. But still installing wine throws the same error Feb 9 '20 at 15:42
  • I'm a bit clueless as to why the same error occurs. What is the output of apt policy wine-stable libblkid1? Another option could be to clean the apt cache manually...
    – Freddy
    Feb 9 '20 at 17:42
  • I've just pasted the result of apt policy wine-stable libblkid1 in the original question. Is this where the error is coming from? Feb 9 '20 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.