1

I tried the methods on this page https://wiki.debian.org/SynapticsTouchpad but it does not work. Actually I also tried methods here Touchpad not working on Debian 9 by adding

deb http://deb.debian.org/debian stretch-backports main

and

apt-get -t stretch-backports install linux-image-4.19.0-0.bpo.2-amd64 linux-image-amd64

does not get anything

My computer is Lenovo L580, currently my source is

deb http://ftp.debian.org/debian stable main contrib non-free
deb-src http://ftp2.de.debian.org/debian/ stable  main contrib non-free

1 Answer 1

1

Try booting with kernel parameter

psmouse.elantech_smbus=0

See Kernel Boot Parameters (Ubuntu Wiki) how to add the parameter temporarily for testing and permanently.

It would only make sense to use stretch-backports if you were running Debian 9 stretch (which you are not). Backports are packages for the next release ("testing") compiled to work with the current "stable" release.

Related:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .