0

ScreenShot of the error

So I was trying to install RuneLite on Manjaro, and at first it built, but it wouldn't launch. I checked the faq on their github and it they said that it had to do with a bug with JDK 10+, and to just set it to a lower version. So I was trying that by uninstalling and reinstalling runelite, but that wasn't working (I tried what they said by removing /usr/lib/jvm/java-11-openjdk-amd64/conf/accessibility.properties but it would say it doesn't exist or something, can't remember). Reinstalling it wouldn't give me the prompt for choosing my JDK version. So my dumbass was like "I'll just go to the jvm folder and delete it as a whole, that should work". So I did that, and uninstalled runelite, only to see that in the package manager I could've just looked at the dependencies and just removed from there (and that it was different from the jvm folder). Did that and so when I rebuilt, I got the prompt for choosing my jdk version, so that worked, but when it tries to build runelite I now get this.

Thanks for any help. I'm still a scrub at linux (day 4 now I think), so any all help is appreciated.

4
  • Why not just use the .jar? java -jar runelite.jar
    – cutrightjm
    Feb 7, 2020 at 1:53
  • would that work? From what I'm seeing with the package manager, it's aborting building runelite right now in general, so is there even anything to run? Feb 7, 2020 at 3:02
  • No, you can just download the .jar directly from their site. Click the Download button, and it's the "Download for all platforms" option
    – cutrightjm
    Feb 7, 2020 at 3:51
  • 1
    So I've made some progress. When I run the jar file with java I get the error > bash: /usr/bin/java: No such file or directory Currently looking into it myself. Will update if I figure it out or not. Feb 7, 2020 at 4:24

1 Answer 1

0

You will need the environment variable JAVA_HOME to be set so that Maven knows which JDK to use to build with. Before setting this variable, you must find your system's JDK path. I am using a Debian system, where a symlink to my JDK is present at /usr/lib/jvm/default-java, but your installation may be found elsewhere—use the path found on your system for the steps below.

Once you have your JDK path, for this operation, you can set this variable in a number of ways:

  1. Set it in a profile script so it is set on each login. I do so for my environment with the following line in my ~/.bash_profile:
    export JAVA_HOME=/lib/jvm/default-java
    
  2. If you are building in your terminal, you can export the above environment variable in your rc file (such as ~/.bashrc) or run that line before executing your mvn command
  3. Again, if you are building in your terminal, you can export this variable exclusively for this command by prepending it to your mvn command:
    JAVA_HOME=/lib/jvm/default-java mvn install ...
    

Keep in mind, if you are only trying to run RuneLite, you do not need to build from source. RuneLite's homepage provides download links for the launcher in both .jar and .AppImage formats, which can be launched via java -jar RuneLite.jar and RuneLite.AppImage, respectively. Furthermore, RuneLite also maintains the snapcraft distribution of the launcher, which should run on its own without any need to configure your Java setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.