1

I have configured PCManFM to use "list" view by default; however, it reverts back to "icon" view on its own.

This is my configuration:

~/.config/pcmanfm/default/pcmanfm.conf

[config]
bm_open_method=0

[volume]
mount_on_startup=1
mount_removable=1
autorun=1

[ui]
always_show_tabs=0
max_tab_chars=32
win_width=636
win_height=1060
splitter_pos=385
media_in_new_tab=0
desktop_folder_new_win=0
change_tab_on_drop=1
close_on_unmount=1
focus_previous=0
side_pane_mode=hidden;places
view_mode=list
show_hidden=0
sort=name;ascending;
toolbar=newtab;navigation;home;
show_statusbar=1
pathbar_mode_buttons=0

Shortly thereafter, it turns into this:

[config]
bm_open_method=0

[volume]
mount_on_startup=1
mount_removable=1
autorun=1

[ui]
always_show_tabs=0
max_tab_chars=32
win_width=836
win_height=1030
splitter_pos=1
media_in_new_tab=0
desktop_folder_new_win=0
change_tab_on_drop=1
close_on_unmount=1
focus_previous=0
side_pane_mode=places
view_mode=icon
show_hidden=0
sort=name;ascending;
toolbar=newtab;navigation;home;
show_statusbar=1
pathbar_mode_buttons=0

View mode gets changed to icon.

I even tried setting the file to be immutable :) and ... no dice (I closed all running instances). Is PCManFM respecting the configuration, or is there some configuration file floating around somewhere else?

| improve this question | | | | |
  • Your configuration works for me. – Devon Feb 7 at 14:45
  • What version of pcmanfm are you on? I am using x11-misc/pcmanfm-1.3.1:0 (funtoo). – Walter Feb 7 at 15:17
  • I am using version 1.3.1 from Arch Linux. – Devon Feb 7 at 17:22
  • Interesting, it shouldn't matter, but my rootfs is squashfs with an overlayfs backing store. Would it depend on any other libraries like libfm? – Walter Feb 7 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.