3

Please help me guys. I'm losing my mind trying to dual boot my machine.

Here is the specs of my machine:

  • acer 4755g
  • SSD for windows 10 and HDD for CentOS 8 (partition, not whole disk is used)

Problem:

  • CentOS grub cannot detect windows 10 bootloader.

Here are the steps that I have done to correct it:

  • Installed ntfs-3g and ran sudo grub2-mkconfig > /dev/null. It still does not see the windows boot loader. In fact, sudo grub2-mkconfig > /dev/null returns nothing.

  • Also tried to manually add chainloder on grub, still nothing.

  • os-prober does not return anything

Possible reason for the problem

  • Windows 10 is installed using BIOS and CentOS is using UEFI

I'm just confused on how CentOS managed to install UEFI on my machine. I'm pretty sure that my machine only supports BIOS. Note: To make the bootable USB, I used rufus with the MBR option.

FINAL NOTE:

I think if I convert the bootloader of CentOS from UEFI to BIOS, this problem will be solved. But can it be converted and How?

0

Yes, looks like BIOS/UEFI mix; refind built with the other toolchain, not GNU EFI (forgot the name, sorry), can support booting BIOS/CSM/Legacy targets from EFI mode.

But I'm pretty sure you'd prefer to have that dualboot aligned with regard to firmware in the end, be it BIOS/BIOS or UEFI/UEFI; it is NOT possible to install UEFI bootloader on BIOS-booted system (even if it's an UEFI-capable system in "legacy" mode).

See also Refind's author's excellent explanation of UEFI bootloaders, it helped me implement UEFI support in ALT Linux back then.

| improve this answer | |
  • When you say "it is NOT possible to install UEFI bootloader on BIOS-booted system", does that mean my machine can actually support UEFI?..I tried to install windows 10 on gpt/uefi but failed..Is there anyway I can force CentOS to install in bios legacy mode? – diode121 Feb 6 at 14:24
  • I mean that if CentOS is installed in UEFI mode (there's /sys/firmware/efi/ directory on a booted system) then your system has UEFI firmware indeed; it can have BIOS mode support via CSM/Legacy mode (but newer hardware was to drop it eventually IIRC). You can boot CentOS installation media in BIOS mode if there are two boot manager records for the boot media or if you disable UEFI booting at all for that particular boot event at least. The links above have it all well covered :-) – Michael Shigorin Feb 8 at 20:05
0

Have you installed ntfs support? Here is what worked for me:

sudo yum install epel-release
sudo yum install ntfs-3g

Then make a copy of your grub configuration file: cd /boot/grub2

sudo cp grub.cfg grub.cfg.bak

and finally create a new grub configuration:

sudo grub2-mkconfig -o /boot/grub2/grub.cfg
| improve this answer | |
0

I had the same issues with Windows 10 and Ubuntu 20.04 (and Centos 8) Following steps are applicable for any Windows 10 and Linux dual-boots. Please check that your laptop supports UEFI, UEFI enabled in BIOS and Linux is installed in UEFI mode.

  1. Install Window 10

  2. Install Linux

  3. Install os-prober to Linux (if not installed)

  4. Boot into Windows 10

  5. Disable fast boot and hybernate. Run in elevated cmd:

    powercfg.exe /hibernate off

  6. Reboot in recovery mode (press Shift and choose Reboot)

  7. Choose command line (in recovery mode) and enter:

    mbr2gpt.exe /convert

    Please note, that you will not able to boot Windows without UEFI in this case.

  8. Boot into Linux and update grub depending on your Linux For CentOS8: grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg Generating grub configuration file ... Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi done For Ubuntu: os-prober update-grub2

  9. You can now reboot and see Windows Boot Manager in GRUB menu

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.