0

Hi there i new to linux and I just enable Raid 10 as a result i can only connect through a putty session and not remote desktop, everything was working fine untill i followed this article

https://magpi.raspberrypi.org/articles/build-a-raspberry-pi-nas

I have tried to enable the VNC server which was enabled previously and i have tried to insta xrdp again which i did previously

this is part of the error message I am getting

Could not open file /var/lib/apt/lists/partial/raspbian.raspberrypi.org_raspbian_dists_buster_Release - open (13: Permission denied) [IP: 93.93.128.193 80]

Reading package lists... Done W: Not using locking for read only lock file /var/lib/apt/lists/lock W: Problem unlinking the file /var/lib/apt/lists/partial/raspbian.raspberrypi.org_raspbian_dists_buster_InRelease - PrepareFiles (13: Permission denied) W: Problem unlinking the file /var/lib/apt/lists/partial/archive.raspberrypi.org_debian_dists_buster_InRelease - PrepareFiles (13: Permission denied) W: Problem unlinking the file /var/lib/apt/lists/partial/raspbian.raspberrypi.org_raspbian_dists_buster_Release - PrepareFiles (13: Permission denied) E: The repository 'http://raspbian.raspberrypi.org/raspbian buster Release' no longer has a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. W: Problem unlinking the file /var/lib/apt/lists/partial/archive.raspberrypi.org_debian_dists_buster_Release - PrepareFiles (13: Permission denied) E: The repository 'http://archive.raspberrypi.org/debian buster Release' no longer has a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (30: Read-only file system) W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (30: Read-only file system)

  • I assume you are root or used sudo so you have the permissions. Then, it seems to be I/O errors. Try sudo mount -o remount,rw / – Munzir Taha Feb 4 '20 at 20:25
  • I just tried and i get the message saying For more details see mount(8). pi@NAS:~ $ mount -o, mount: only root can use "--options" option – Nick Feb 5 '20 at 21:01
  • Did you solve this?, I got into the same, installed octoprint distro, the files mentioned "/var/lib/apt/lists/partial/raspbian.raspberrypi.org_raspbian_dists_buster_Release", but has name "/var/lib/apt/lists/partial/raspbian.raspberrypi.org_raspbian_dists_buster_InRelease" but I don't see what the problem is.. And yes, using sudo, but getting messages that filesystem, is readonly. – neslekkiM Jun 19 '20 at 20:37
0

You need to be root or use sudo commamd

https://www.raspberrypi.org/documentation/linux/usage/root.md

e.g. instead of doing

$ apt install xrdp

you do

$ sudo apt install xrdp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.