0

Newly created files and directories with the CAJA browser (e.g. in MATE desktop in Debian 9) seem impervious to whatever umask setting you set in /etc/profile.

Where can I change the default permissions of the newly created files and directories by the CAJA browser?

1 Answer 1

-1

Assuming you're login shell is Bash, setting umask at the end of ~/.bashrc changes default permissions of new items created by Caja as well as everywhere else in your userspace. Depending on what's present on your system, adding the setting instead to the end of ~/.bash_profile, ~/.bash_login, or ~/.profile should have the same effect.

For other shells, adding the setting to the appropriate shell initialization file should have the same effect.

3
  • Thank you, David, but it doesn´t work. The empty directories and files created from caja still ignore it.
    – Mephisto
    Feb 4, 2020 at 18:20
  • Sorry to hear that. I tested on my own machine before posting, but I'm running Fedora with Xfce rather than Debian with MATE, so that could be the difference. Feb 4, 2020 at 19:30
  • Incidentally, did you log out and log back in before testing in Caja? That would be necessary for the change to take effect. Feb 4, 2020 at 19:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .