I want to install a Latex package, so I run:

(env) mvh:~$ tlmgr install verbatim
(running on Debian, switching to user mode!)
tlmgr: Remote repository is newer than local (2017 < 2019)
Cross release updates are only supported with
  update-tlmgr-latest(.sh/.exe) --update
Please see https://tug.org/texlive/upgrade.html for details.

I go to the website linked above and download and run update-tlmgr-latest.sh, and I get:

(env) mvh:Downloads$ bash update-tlmgr-latest.sh 
Verifying archive integrity... All good.
Uncompressing TeX Live Manager Updater  100%  
./runme.sh: Cannot find TeX Live root using kpsewhich --var-value=SELFAUTOPARENT.
./runme.sh: (no tlpkg/texlive.tlpdb and/or tlpkg/tlpobj/.)
./runme.sh: Please set your PATH as needed, otherwise it's hopeless.

This despite the fact that in my ./bashrc, I have:

export PATH=$PATH:/usr/share/texlive/

And indeed, if I check where texlive is, using whereis, I get exactly the directory above. Interestingly, the instructions linked above seem to want there to be a folder with a year in its name in the texlive install.


  1. Find the parent directory of the current installation; it's /usr/local/texlive by default.

  2. Copy the whole directory 2018 to 2019, preserving symbolic links; for example: cp -a 2018 2019 If you don't understand this, stop here and do a regular installation.

However, I appear to have no such folders ...

(env) mvh:texlive$ whereis texlive
texlive: /usr/share/texlive
(env) mvh:texlive$ cd
(env) mvh:~$ whereis texlive
texlive: /usr/share/texlive
(env) mvh:~$ cd /usr/share/texlive
(env) mvh:texlive$ ls
debian  doc.html  index.html  LICENSE.CTAN  LICENSE.TL  README  readme-html.dir  readme-txt.dir  README.usergroups  release-texlive.txt  texmf-dist  tlpkg

I am running Linux Mint 19.3 Cinnamon, and I installed texlive-full using sudo apt-get install texlive-full. So far, I have tried, to no avail: (this), (this), the instructions under 2. (here), most of (this), and (this). I also tried this solution, to no avail:

(env) root:texlive# sudo tlmgr option repository ftp://tug.org/historic/systems/texlive/2017/tlnet-final
(running on Debian, switching to user mode!)
tlmgr: setting default package repository to ftp://tug.org/historic/systems/texlive/2017/tlnet-final
(env) root:texlive# tlmgr update --self
(running on Debian, switching to user mode!)
/usr/bin/tlmgr: open tlpdb(ftp://tug.org/historic/systems/texlive/2017/tlnet-final/tlpkg/texlive.tlpdb) failed:  at /usr/share/texlive/tlpkg/TeXLive/TLPDB.pm line 362.

How can I update tlmgr so I can install packages (and do my homework)? Thanks!

  • 1
    Are you sure you need to install verbatim? It’s part of the LaTeX tools package, which is included in the basic installation of LaTeX. In Linux Mint, it’s part of the texlive-latex-base package (sudo apt install texlive-latex-base if you don’t have it already). verbatim hasn’t changed since 2003. Feb 3, 2020 at 8:00
  • Thanks for pointing this out - I just used verbatim as an example. I really need code and ttquot. For now I am temporarily just using sty Giles but I would prefer to actually have a working tlmgr installation so I can easily install these packages globally, and also to handle this situation in the future without needing to rely on apt cache searching for something that happens to include what I want ... thanks. Feb 3, 2020 at 14:51

1 Answer 1


Starting from a Debian-packages TeX Live installation, I would recommend always running tlmgr as yourself, not root:

tlmgr init-usertree

will set your user tree up, and then

tlmgr option repository ftp://tug.org/historic/systems/texlive/2017/tlnet-final

should be used to point tlmgr at the repository matching your installation (2017 for Linux Mint, 2018 for Debian 10, etc.).

Once that’s done,

tlmgr install ...

will install the package you’re after, assuming it’s available (which isn’t the case for either code or ttquot).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .