1

I don't really know how to add this rule to the profile, since the name was "wired", it's not some absolute path on my system,

kernel: type=1400 audit(1353749970.556:556): apparmor="ALLOWED" operation="open" parent=1 profile="/usr/lib/firefox/firefox{,*[^s][^h]}" name=2F4170706C69636174696F6E2F7468656D65732F4C696F6E2D7468656D652D72656C6F61646564202F67746B2D322E302F67746B7263 pid=14778 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=1000

Anyone know what sort of rules should I add to firefox's profile? With this unknown stuff denied from reading, firefox looks ugly (no gtk themes applied)

2
  • 1
    Just in case, that hex string is /Application/themes/Lion-theme-reloaded /gtk-2.0/gtkrc. Yes, with the space in the middle. No idea why it was written that way or why it's there. Commented Nov 24, 2012 at 14:20
  • @Gilles that was a mistake to have a space at the end of it, probably it was there before the author packed the theme ... anyway, the problem got solved now
    – daisy
    Commented Nov 24, 2012 at 15:01

1 Answer 1

1

The string is encoded because it contains special chars,

Decoded the string with aa-decode 2F4170706C69636174696F6E2F7468656D65732F4C696F6E2D7468656D652D72656C6F61646564202F67746B2D322E302F67746B7263 and found out the issue was caused by a newly introduced GTK theme.

Now it's fixed, just simple add a line to that profile, i.e /Application/themes/** r,

3
  • Just curious but what is the advantage of keeping themes in /Application and not in ~/.themes or /usr/share/themes?
    – user15760
    Commented Nov 30, 2012 at 10:35
  • @vasa1 just some old partition scheme ... I don't even remember why I did that
    – daisy
    Commented Nov 30, 2012 at 10:39
  • 1
    @vasa1 I just remember the reason. I run both Ubuntu and Arch .. themes need to be shared through a common disk partition
    – daisy
    Commented Nov 30, 2012 at 10:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .