0

I have a Dell Latitude e6400 laptop, that I am trying to install on from a USB drive, the BIOS Recognizes the hard drive and also lists the hard drive size, but during install from USB, OpenBSD is only recognizing the USB drive, no others. Previously I successfully installed OpenBSD on another Dell laptop I have, using the same .fs file from USB, and there was no problem like this with the install. Has anyone else encountered this issue?

5
  • OK, I think it might actually be a defective hard drive connector on the Dell Latitude e6400 laptop, I am next going to try to install Ubuntu Linux, a USB install, and that should tell me if it is the laptop that is the problem. Commented Feb 1, 2020 at 21:54
  • OK, I was able to successfully install Ubuntu Linux on the same Dell Latitude e6400 laptop that the OpenBSD installer .fs file would not recognize the hard drive, i think the FS file has somehow been corrupted, another day when I have time I am going to redownload the FS file, burn it to usb drive, and try to install OpenBSD again, and see if that fixes the problem. If that is the answer I will post it as the answer to this post. Commented Feb 2, 2020 at 0:17
  • Possible duplicate of this. Check if you have your controller configured as RAID instead of AHCI/SATA.
    – Zé Loff
    Commented Feb 3, 2020 at 14:53
  • Ok thanks for the input, I would be really surprised if he hard drive controller is set to RAID, normally RAID is only used by servers, in particular rack mounted servers. I will check this out today though. Commented Feb 4, 2020 at 16:20
  • Ok GREAT!! YAY!! changing the drive in BIOS to AHCI fixed the issue, now OpenBSD recognizing the hard drive and install underway, thanks for your help Ze Loff!! Commented Feb 4, 2020 at 18:16

1 Answer 1

1

Ok, the solution to this problem with OpenBSD Unix USB Install not recognizing the hard drive, the solutions was to change the hard drive settings to AHCI in BIOS, that fixed the issue, afterwards was able to install OpenBSD no problem!

Special thanks to Zé Loff for pointing in the right direction for the solution! :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .