0

I was trying to use Ubuntu using Oracle Virtualbox 6.1.2.

I cannot make the Ubuntu size full screen. I now have a tiny window with a lot of black background. When I tried inserting guest additions cd image (from Menu -> devices), I got the error message:

Could not mount the media (VERR_PDM_MEDIA_LOCKED)

Could not mount the media(VERR_PDM_MEDIA_LOCKED) error message

And when I tried executing the code sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 in the Ubuntu terminal, I got the error message,

Some packages could not be installed.

Some packages could not be installed - error message in the terminal

So, how can I increase the present small Ubuntu screen size?

  • You might have the install-media already mounted. A reboot and unmount is usually enough to get past that point. – Thomas Dickey Feb 1 at 11:21
  • Thanks @Thomas Dickey. When you say reboot, you mean restart the VM Machine? I have done it several times. How do I unmount the install-media? – Sreejish Feb 1 at 11:36
  • I'd use "mount" to show what is mounted, and then "sudo umount whatever" ("whatever" the mount-point is, e.g., /media/some, /cdrom, etc). – Thomas Dickey Feb 1 at 11:37
  • Thanks @ThomasDickey. When I used the mount command in the terminal, the only line with media in it is /dev/sr0 on /media/deeplearningcv/VBox_GAs_6.1.2 type iso9660 (ro,nosuid,nodev,relatime,nojoliet,check=s,map=n,blocksize=2048,uid=1000,gid=1000,dmode=500,fmode=400,uhelper=udisks2). So, should I be using the command, sudo unmount media/deeplearningcv/VBox_GAs_6.1.2? Then again, should I mount the same using the mount command? – Sreejish Feb 1 at 11:51
  • Either the media which is mounted can be run for the current machine (no remounting needed), or unmounting/remounting is the way to go. – Thomas Dickey Feb 1 at 12:52
0

I was able to resolve the issue yesterday by following the YouTube video: https://www.youtube.com/watch?time_continue=267&v=WiYNrx1Grak&feature=emb_logo

But, later after several hours, the small screen size problem again resurfaced. The problem was again resolved by installing VirtualBox 6.1.2 Oracle VM VirtualBox Extension Pack from https://www.virtualbox.org/wiki/Downloads. This helped to get access to webcam in the virtual machine as well.

But, for some reason, today my virtual machine is not booting. That could be a totally different issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.