0

I have machine with AV Linux (variety of Debian 10) and Windows 10. Originally I had Ubuntu and Windows and installed AV Linux in the /dev/sda7 partition. This broke the grub boot loader.

When I boot the machine I am presented with a Grub 2.0 prompt. I also notice that in the bios boot priority section, the options given are Windows and "Ubuntu", ie. not AV Linux or Debian.

Both Windows and AV Linux are OK and I can boot into them via the grub 2 prompt that presents itself at start up.

I boot into Linux with:

set root=(hd0,7)
linux /boot/vmlinuz-5.0.7-rt5av11 root=/dev/sda7
initrd /boot/initrd.img-5.0.7-rtav11
boot

fdisk -l shows:

Device          Start        End    Sectors   Size Type
/dev/sda1        2048     206847     204800   100M EFI System
/dev/sda2      206848     468991     262144   128M Microsoft reserved
/dev/sda3      468992 1018656447 1018187456 485.5G Microsoft basic data
/dev/sda4  1918676992 1920569343    1892352   924M Windows recovery environment
/dev/sda5  1920569346 1951426562   30857217  14.7G Windows recovery environment
/dev/sda6  1951426563 1953523715    2097153     1G Windows recovery environment
/dev/sda7  1018656768 1918676991  900020224 429.2G Linux filesystem

I created the directory /boot/efi and tried various things to update grub. For example:

sudo mount /dev/sda1 /boot/efi/   
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=debian --recheck --debug /dev/sda 
sudo update-grub2

But I'm returned to the grub prompt on reboot. I've also tried sudo update-grub. Note also, the grub-install always yields:

grub-install: warning: EFI variables are not supported on this system..

sudo update-grub2 seems to run ok and yields:

Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-5.0.7-rt5avl1
Found initrd image: /boot/initrd.img-5.0.7-rt5avl1
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Found linux image: /boot/vmlinuz-5.0.7-rt5avl1
Found initrd image: /boot/initrd.img-5.0.7-rt5avl1
done

I installed grub-customizer. Debian, Advanced options for Debian and Windows Boot Manager are all displayed. If I edit the Debian entry is see the following in the boot sequence field:

load_video
insmod gzio
if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
insmod part_gpt
insmod ext2
set root='hd0,gpt7'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt7 --hint-efi=hd0,gpt7 --hint-baremetal=ahci0,gpt7  ba95278e-9d8d-4bf0-9a2a-d6fcaf9e88aa
else
  search --no-floppy --fs-uuid --set=root ba95278e-9d8d-4bf0-9a2a-d6fcaf9e88aa
fi
echo    'Loading Linux 5.0.7-rt5avl1 ...'
linux   /boot/vmlinuz-5.0.7-rt5avl1 root=UUID=ba95278e-9d8d-4bf0-9a2a-d6fcaf9e88aa ro  threadirqs transparent_hugepage=never noresume quiet
echo    'Loading initial ramdisk ...'
initrd  /boot/initrd.img-5.0.7-rt5avl1

Generated boot info file with the utility Boot Repair (which couldn't repair the problem itself). Please see:

http://paste.ubuntu.com/p/Vm7PhphxD6/

| improve this question | | | | |
  • I'm at a complete loss. Should I reinstall grub? – sebinho Feb 1 at 12:42
  • This has the wrong UUID: sda1/EFI/ubuntu/grub.cfg Normally full reinstall of grub in UEFI mode adds new entry to ESP sudo efibootmgr -v to see that and updates the 3 line configfile grub to full grub install in ESP. I think Debian adds its own /EFI/debian or /EFI/grub folders into UEFI. – oldfred Feb 1 at 15:14
  • Thanks. I tried reinstalling but encountered issues with dependencies. In the end I gave up and installed Linux Mint on the partition. The installer for this handled the dual boot with no problems what so ever. All fixed now. – sebinho Feb 2 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.