0

I just tried to encrypt the new 2 TB disk I just received. Unfortunately I unplugged it (external disk on a USB port) just after running a cryptsetup command and now I cannot even list it with fd or lsblk commands.

The steps I followed:

1/ Create a new ext4 partition on the disk => OK

2/ Run command: >sudo cryptsetup luksFormat -c aes-xts-plain64 -s 512 -h sha512 /dev/sdh1

The command processed until the end with no problem.

3/ Unplug the USB cable

I (re)plugged the disk and it cannot be listed anymore. Tried df, lsblk, KDE partition manager. I also tried on another linux laptop with no success.

Any idea what could happen and how to fix the issue?

Thanks

  • 1
    Can you see the disk with fdisk? If so you might need to delete the partition table and recreate it – Dexirian Jan 30 at 18:32
  • Nope, I forgot to mention that fdisk doesn't list the disk either. – Nitseg Jan 31 at 1:22
0

I finally installed the disk as the main disk of a laptop, ran an Ubuntu installation disk and it made it. It could be listed and formatted. I will probably never know why but the problem is solved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.