1

I see a lot of questions across SE about getting sound to work with KVM guests, whether using Spice or Pulseaudio. However, I would like the opposite. I would like no sound whatsoever to be passed from guest to host, using libvirt with virt-manager. Whenever I log in to a VM's graphical lockscreen or connect to an already-logged-in VM (using the built in Spice viewer or Remmina), the sample rate for my USB audio interface changes, and all sounds from the host increase in pitch until I open the host's audio menu or the Pulseaudio volume control (pavucontrol).

Of course, I have removed the ICH9 sound device from the VM's configuration, and do not have any USB passthrough or forwarding configured. I have also checked Pulseaudio's configuration on the host, and I do not see the TCP module enabled.

I have tried disabling Pulseaudio completely in the guest, and confirmed that it is not running.

My host is running Fedora 32 with the sound provided by Pulseaudio in a near-default configuration.

1 Answer 1

1

Try adding the -audiodev id=none,driver=none option to qemu.

1
  • Unfortunately, I tried this and there is no change. I will add a couple more details to the question. Sep 14, 2020 at 23:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .