1

we want to remove openssl-libs and to installed diff openssl version

but yum remove option have huge dependencies list and failed as the following:

yum remove openssl-libs
.
.
.
.
.


---> Package spax.x86_64 0:1.5.2-13.el7 will be erased
---> Package speex.x86_64 0:1.2-0.19.rc1.el7 will be erased
---> Package startup-notification.x86_64 0:0.12-8.el7 will be erased
---> Package taglib.x86_64 0:1.8-7.20130218git.el7 will be erased
---> Package tcp_wrappers.x86_64 0:7.6-77.el7 will be erased
---> Package tcp_wrappers-libs.x86_64 0:7.6-77.el7 will be erased
---> Package telepathy-filesystem.noarch 0:0.0.2-6.el7 will be erased
---> Package telepathy-glib.x86_64 0:0.24.0-1.el7 will be erased
---> Package telepathy-logger.x86_64 0:0.8.0-5.el7 will be erased
---> Package tigervnc-license.noarch 0:1.3.1-3.el7 will be erased
---> Package ttmkfdir.x86_64 0:3.0.9-42.el7 will be erased
---> Package tzdata-java.noarch 0:2015g-1.el7 will be erased
---> Package urw-fonts.noarch 0:2.4-16.el7 will be erased
---> Package usbredir.x86_64 0:0.6-7.el7 will be erased
---> Package vte-profile.x86_64 0:0.38.3-2.el7 will be erased
---> Package wavpack.x86_64 0:4.60.1-9.el7 will be erased
---> Package webrtc-audio-processing.x86_64 0:0.1-5.el7 will be erased
---> Package xcb-util.x86_64 0:0.4.0-2.el7 will be erased
---> Package xkeyboard-config.noarch 0:2.14-1.el7 will be erased
---> Package xml-common.noarch 0:0.6.3-39.el7 will be erased
---> Package xmlrpc-c.x86_64 0:1.32.5-1905.svn2451.el7 will be erased
---> Package xorg-x11-font-utils.x86_64 1:7.5-20.el7 will be erased
---> Package xorg-x11-fonts-Type1.noarch 0:7.5-9.el7 will be erased
---> Package xorg-x11-server-common.x86_64 0:1.17.2-10.el7 will be erased
---> Package xorg-x11-server-utils.x86_64 0:7.7-14.el7 will be erased
---> Package xorg-x11-xkb-utils.x86_64 0:7.7-12.el7 will be erased
---> Package yajl.x86_64 0:2.0.4-4.el7 will be erased
---> Package yelp-xsl.noarch 0:3.14.0-1.el7 will be erased
--> Finished Dependency Resolution
Error: Trying to remove "systemd", which is protected
Error: Trying to remove "yum", which is protected

in the last lines we see remove systemd and yum

Error: Trying to remove "systemd", which is protected
Error: Trying to remove "yum", which is protected

how we can force yum remove in order to remove openssl-libs rpm?

we also tried to downgrade

    yum downgrade openssl-libs  --skip-broken
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
configuration
    Resolving Dependencies
    --> Running transaction check
    ---> Package openssl-libs.x86_64 1:1.0.2k-16.el7_6.1 will be a downgrade
    ---> Package openssl-libs.x86_64 1:1.0.2k-19.el7 will be erased

    Packages skipped because of dependency problems:
        1:openssl-libs-1.0.2k-16.el7_6.1.x86_64 from rhel-7-server-rpms
    Error: Success - empty transaction
5
  • but the suggestion that you give me also remove important dependence , second why yum try to remove systemd and yum itself?
    – yael
    Jan 27 '20 at 4:23
  • 1
    Removing openssl-libs will destroy your system. It has several dependents like python on which yum depends and coreutils on which systemd depends. It would also remove bash and glibc which would be equivalent to throwing the system out into traffic. Jan 27 '20 at 5:27
  • so how to downgrade the openssl rpm?
    – yael
    Jan 27 '20 at 5:29
  • see my update - yum downgrade openssl-libs --skip-broken
    – yael
    Jan 27 '20 at 5:34
4

When you want to remove some package (e.g., their-openssl) and replace it with some other package (e.g., my-openssl) and not break deps in meantime you can use

yum swap -- remove their-openssl -- install my-openssl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.